summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/homescreen
diff options
context:
space:
mode:
authorBocklage, Jens <Jens_Bocklage@mentor.com>2017-01-20 13:09:57 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-25 15:13:02 +0000
commite9da2ae427ac8631e3f62915850adba4cfcf40ed (patch)
tree97fbae2f9af024d094a005c418f00f122ebcc74a /recipes-demo-hmi/homescreen
parentd433feb00e927c727558f6894ad9ba53b8dac2fa (diff)
Split homescreen recipe into new recipes
The homescreen recipe used to build several components. These have their own recipes now. Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
Diffstat (limited to 'recipes-demo-hmi/homescreen')
-rw-r--r--recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in14
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb79
2 files changed, 13 insertions, 80 deletions
diff --git a/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in b/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in
deleted file mode 100644
index 1a70c9ac..00000000
--- a/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in
+++ /dev/null
@@ -1,14 +0,0 @@
-prefix=OEPREFIX
-exec_prefix=OEPREFIX
-libdir=OELIBDIR
-includedir=OEINCDIR
-
-
-Name: libhomescreen
-Description: A generic interface for the HomeScreen app
-Version: 1.0.0
-Libs: -L${libdir} -lhomescreen
-Libs.private: -lgio-2.0 -lgobject-2.0 -lglib-2.0
-Cflags:
-Requires: glib-2.0 gio-unix-2.0
-
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index 2115804b..ee4d03ba 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -1,97 +1,44 @@
SUMMARY = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager"
-HOMEPAGE = "https://wiki.automotivelinux.org/homescreen"
+DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate"
+HOMEPAGE = "http://docs.automotivelinux.org"
LICENSE = "Apache-2.0"
SECTION = "apps"
S = "${WORKDIR}/git/"
-BBCLASSEXTEND = " nativesdk"
-
inherit qmake5 systemd pkgconfig
-DEPENDS = " qtbase "
-
-# for HomeScreenAppFrameworkBinderTizen:
-#DEPENDS += " pkgmgr-info aul "
-# for WindowManager:
-DEPENDS += " wayland-ivi-extension "
-# for libhomescreen
-DEPENDS += " glib-2.0 "
-# for sample apps
-DEPENDS += " qtdeclarative qtquickcontrols2 "
+DEPENDS = " qtbase qtdeclarative qtquickcontrols2 "
+RDEPENDS_${PN} = " \
+ homescreenappframeworkbinderagl \
+ inputeventmanager \
+ windowmanager"
-LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRCREV = "${AUTOREV}"
# PV needs to be modified with SRCPV to work AUTOREV correctly
PV = "0.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
- file://homescreen.pc.in \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=http \
file://dbus-homescreen.conf.in"
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
do_install() {
install -d ${D}/usr/AGL/${PN}
- install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/SampleHomeScreenInterfaceApp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/HomeScreenAppFrameworkBinderAGL/HomeScreenAppFrameworkBinderAGL ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
-
- install -d ${D}${libdir}
- install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
- ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
- ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
- ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
+ install -m 0755 ${B}/homescreen/HomeScreen ${D}/usr/AGL/${PN}/
+ install -m 0755 ${B}/sampleapptimedate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
# claneys: add dbus policy to make wifi/bluetooth status icon working as quick
# workaround. (jira.automotivelinux.org : SPEC-377)
install -d ${D}/etc/dbus-1/session.d
install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
-# kooltux: still some problem with paths inside .pc file
-# error at build time:
-# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
-#
- install -d ${D}${libdir}/pkgconfig
- install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
- sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
- sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
- sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
-
- install -d ${D}${includedir}
- install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
-
install -d ${D}${systemd_user_unitdir}
- install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
- install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_user_unitdir}
- install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
- install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_user_unitdir}
+ install -m 0644 ${S}/homescreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
install -d ${D}${sysconfdir}/systemd/user/default.target.wants
- ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
}
-FILES_${PN} += "/usr/AGL/${PN}/ ${libdir} ${systemd_user_unitdir}"
+FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
-
-PACKAGES =+ "libhomescreen libhomescreen-dev libhomescreen-dbg"
-
-FILES_libhomescreen = "\
- ${libdir}/libhomescreen.so.* \
-"
-FILES_libhomescreen-dev = "\
- ${includedir}/libhomescreen.hpp \
- ${libdir}/libhomescreen.so \
- ${libdir}/pkgconfig/homescreen.pc \
-"
-FILES_libhomescreen-dbg = "\
- ${libdir}/.debug/libhomescreen.so.* \
-"
-RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
-
-RDEPENDS_${PN}-dev += "libhomescreen-dev"
-