summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/html5-dashboard
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-06 19:03:29 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 14:57:14 +0000
commit2e014bfbd0757f2e35559543ba78d95cbc88b2c5 (patch)
treeb219a82002a0c17ebc4f7636f4e0bc368c2aa8e2 /recipes-demo-hmi/html5-dashboard
parent5000d2e090cc2c8df74a7a96804882e8e74d9bdf (diff)
html5-dashboard: create recipe and add to html5 demo
Bug-AGL: SPEC-3151 Change-Id: Iee5fcba63de56f7d326a9015902f63e4d48632bf Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Diffstat (limited to 'recipes-demo-hmi/html5-dashboard')
-rw-r--r--recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
new file mode 100644
index 00000000..534bd2d3
--- /dev/null
+++ b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 dashboard Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}