summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/hvac/hvac_git.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-12-28 18:29:57 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-28 20:57:28 +0000
commit902589932c94a9c9112fa34f25b6ea867e20bc39 (patch)
treeda1a785486443090717bcafcabb9118498adac9b /recipes-demo-hmi/hvac/hvac_git.bb
parent6e15a17484561d9b9865f5402ff8b234615db217 (diff)
Use inherit aglwgt in application recipes
This change converts the application recipes for hvac, mediaplayer, mixer, settings to use the aglwgt bbclass. This simplifies the application workflow and ensures interoperability with the SDK. Change-Id: Icaa8ba3f931844be6063c18957c07aa598591f06 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo-hmi/hvac/hvac_git.bb')
-rw-r--r--recipes-demo-hmi/hvac/hvac_git.bb29
1 files changed, 6 insertions, 23 deletions
diff --git a/recipes-demo-hmi/hvac/hvac_git.bb b/recipes-demo-hmi/hvac/hvac_git.bb
index 4b3e2897..425052cf 100644
--- a/recipes-demo-hmi/hvac/hvac_git.bb
+++ b/recipes-demo-hmi/hvac/hvac_git.bb
@@ -1,35 +1,18 @@
SUMMARY = "HVAC for CES2017 AGL Demonstration"
DESCRIPTION = "AGL HMI Application for demonstrating HVAC on AGL Distribution"
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
-LICENSE = "Apache-2.0"
SECTION = "apps"
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-inherit qmake5
-
-DEPENDS += "qtquickcontrols2"
-# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS += "af-main-native"
-# hvac has binding, so af-binder is required.
-DEPENDS += "af-binder"
-
+LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=http"
SRCREV = "${AUTOREV}"
-RDEPENDS_${PN} += " \
- qtmultimedia-qmlplugins \
- qtquickcontrols2-qmlplugins \
- "
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
-do_install() {
- install -d ${D}/usr/AGL/apps
- install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
-}
+# build-time dependencies
+DEPENDS += "qtquickcontrols2"
-FILES_${PN} += "/usr/AGL/apps/ \
- /usr/AGL/apps/${PN} \
- "
+inherit qmake5 aglwgt