summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/inputeventmanager
diff options
context:
space:
mode:
authorBocklage, Jens <Jens_Bocklage@mentor.com>2017-01-20 13:09:57 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-25 15:13:02 +0000
commite9da2ae427ac8631e3f62915850adba4cfcf40ed (patch)
tree97fbae2f9af024d094a005c418f00f122ebcc74a /recipes-demo-hmi/inputeventmanager
parentd433feb00e927c727558f6894ad9ba53b8dac2fa (diff)
Split homescreen recipe into new recipes
The homescreen recipe used to build several components. These have their own recipes now. Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
Diffstat (limited to 'recipes-demo-hmi/inputeventmanager')
-rw-r--r--recipes-demo-hmi/inputeventmanager/inputeventmanager_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-demo-hmi/inputeventmanager/inputeventmanager_git.bb b/recipes-demo-hmi/inputeventmanager/inputeventmanager_git.bb
new file mode 100644
index 00000000..fff0a2f4
--- /dev/null
+++ b/recipes-demo-hmi/inputeventmanager/inputeventmanager_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "AGL InputEventManager Application"
+DESCRIPTION = "InputEventManager"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+S = "${WORKDIR}/git/"
+
+inherit qmake5 systemd
+DEPENDS = " qtbase "
+
+LIC_FILES_CHKSUM = "file://inputeventmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV = "${AUTOREV}"
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/inputeventmanager.git;protocol=http"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+do_install() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${B}/inputeventmanager/InputEventManager ${D}/usr/AGL/${PN}/
+
+ install -d ${D}${systemd_user_unitdir}
+ install -m 0644 ${S}/inputeventmanager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
+}
+
+FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
+FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
+