summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-25 15:32:55 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-02 12:03:44 +0000
commite96107e981c04b71e81986dc2528e06ae7515488 (patch)
tree35cc7e82c500fdb89a67c9213241010ae33fe5b8 /recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
parentd1ed12cdcc4552695ab461d38a3e466ece2aac69 (diff)
Add a new include file for new framework homescreen
Rename old libhomescreen_git.bb to libhomescreen-old.inc for old homscreen. Add a new include file named libhomescreen-2017.inc for new framework homescreen. In the libhomescreen_git.bb 'require' the respective include file based on DISTRO_FEATURES contains " agl-hmi-framework " or not. [Patch Sets 5] Follow Jan-Simon comments, add new include file. Change old include file SRCREV to old revison. <f5c14333d2170ae9babed53ea530828569a830ff> [Patch Sets 6] Change libhomescreen-2017.inc SRCREV to master revison. <390902a6b002c6af183c939749fdebfcc4b3e839> BUG-AGL: SPEC-993 Change-Id: I4789a25d1079b99fe35917446227bc5ef773dd46 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'recipes-demo-hmi/libhomescreen/libhomescreen-old.inc')
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-old.inc58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc b/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
new file mode 100644
index 00000000..57449b76
--- /dev/null
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
@@ -0,0 +1,58 @@
+LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS += " glib-2.0 "
+
+inherit qmake5 pkgconfig
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=http \
+ file://homescreen.pc.in"
+SRCREV = "f5c14333d2170ae9babed53ea530828569a830ff"
+S = "${WORKDIR}/git/"
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+do_install() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
+
+ install -d ${D}${libdir}
+ install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
+ ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
+ ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
+ ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
+
+# kooltux: still some problem with paths inside .pc file
+# error at build time:
+# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
+#
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
+
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
+}
+
+PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
+
+FILES_${PN} = "\
+ ${libdir}/libhomescreen.so.* \
+"
+FILES_${PN}-dev = "\
+ ${includedir}/libhomescreen.hpp \
+ ${libdir}/libhomescreen.so \
+ ${libdir}/pkgconfig/homescreen.pc \
+"
+FILES_${PN}-dbg += "\
+ ${libdir}/.debug/libhomescreen.so.* \
+"
+
+FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
+FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
+
+
+RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
+