summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/mediaplayer
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-11-15 00:17:42 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-14 16:15:39 +0000
commite96aae7124dff2e42ebdd7eea6415817071b7831 (patch)
treeda11404f6faa59c152975d56b0e49799437dcf54 /recipes-demo-hmi/mediaplayer
parentf2f5947688849550a7aea5db3469994455f4f73e (diff)
Update app DEPENDS for new HMI framework
Add virtual/libhomescreen and qlibwindowmanager as DEPENDS in the recipes of apps that have been updated to use the new HMI framework. Change-Id: Ic5bcceaa4273612d0eaa7d1762177b4a1077ddfb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/mediaplayer')
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
index 8a7fd620..e99eb5bd 100644
--- a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -12,10 +12,15 @@ SRCREV = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit qmake5 aglwgt
-
# build-time dependencies
-DEPENDS += "sqlite3 qtquickcontrols2 qtmultimedia"
+DEPENDS += "sqlite3 \
+ qtquickcontrols2 \
+ qtmultimedia \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
RDEPENDS_${PN} += "qtmultimedia \
qtmultimedia-qmlplugins \