summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/mixer
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2019-06-10 14:51:35 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-11 13:53:50 +0000
commitb68fb7fe0d50bb6118b9d87846639a96940ffe1c (patch)
treea9af30dbcca3292d0f9c27a6e45a71e7d68bad1e /recipes-demo-hmi/mixer
parent644a2d10516118f9a3bb3ae1c7392e9cf38bc650 (diff)
mixer: update to build the pipewire mixer from master
Most changes are based on the 4a-mixer recipe Bug-AGL: SPEC-2473 Change-Id: I290c97836830b1b83d9564dda2c77b526f474f18 Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
Diffstat (limited to 'recipes-demo-hmi/mixer')
-rw-r--r--recipes-demo-hmi/mixer/mixer_git.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes-demo-hmi/mixer/mixer_git.bb b/recipes-demo-hmi/mixer/mixer_git.bb
index b721970f..9524bed6 100644
--- a/recipes-demo-hmi/mixer/mixer_git.bb
+++ b/recipes-demo-hmi/mixer/mixer_git.bb
@@ -1,5 +1,5 @@
SUMMARY = "Mixer for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+DESCRIPTION = "AGL HMI application for control of PipeWire mixer elements"
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
SECTION = "apps"
@@ -7,21 +7,23 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
-
-# 'legacy' version (eel_5.0.3 == master for CES'18) when 4A is not enabled
-SRCREV = "d9bb450ee8898cb810027897a32afd3adcb05d9f"
+SRCREV = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2 \
- pulseaudio \
- libhomescreen \
- qlibwindowmanager \
+ qtwebsockets \
+ qtaglextras \
+ libafb-helpers-qt \
"
+RDEPENDS_${PN} += "agl-service-audiomixer"
+
PROVIDES += "virtual/mixer"
RPROVIDES_${PN} += "virtual/mixer"
-inherit qmake5 aglwgt
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"