summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer-demo.bb
diff options
context:
space:
mode:
authorynakamura <ynakamura@jp.adit-jv.com>2016-12-28 14:57:00 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2017-01-24 21:50:15 +0900
commitd433feb00e927c727558f6894ad9ba53b8dac2fa (patch)
treefc637a163043122abd89bfae7a323e4f2c16c399 /recipes-demo-hmi/navigation/mapviewer-demo.bb
parent172e617762aa1acb951e3543ae646451b2b87026 (diff)
Add switch on/off script for cluster demo
v2.0: (Tadao Tanikawa) Completely rebuilt. The mapviewer and mapvier-demo are installed into porter's image only because they need AGL CES2017 Demo mock-up. To enable mapviewer-demo, execute switch_on_mapviewer-demo.sh at /usr/AGL/mapviewer-demo then reboot porter. CAUTION: After enabling mapviewer-demo, without cluster mock up which connected directly to porter board, weston on the porter board would always crash immediately after booting. If you fall into that situation, disable mapviewer-demo following instructions below. To disable mapviewer-demo, execute switch_off_mapviewer-demo.sh at /usr/AGL/mapviewer-demo then reboot porter. v1.0: (Yusuke Nakamura) This addes script to enable/disable CES2017 cluster demo to /usr/AGL/cluster-demo. Once switch_on_cluster-demo.sh is executed, this enables a service for cluster demo and sets configurations for the dmeo. Change-Id: Ie10f35ff4168095c3b3c6572579a2c4799c04578 Signed-off-by: ynakamura <ynakamura@jp.adit-jv.com> Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer-demo.bb')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo.bb b/recipes-demo-hmi/navigation/mapviewer-demo.bb
new file mode 100644
index 00000000..86e7f93d
--- /dev/null
+++ b/recipes-demo-hmi/navigation/mapviewer-demo.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Setting files of mapviewer for the AGL Demonstrator @ CES2017"
+DESCRIPTION = "Setting files of mapviewer for the AGL Demonstrator @ CES2017"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SECTION = "apps"
+
+inherit systemd
+
+SRC_URI = " \
+ file://switch_off_mapviewer-demo.sh \
+ file://switch_on_mapviewer-demo.sh \
+ file://weston-mapviewer-demo.ini \
+ file://weston-mapviewer-demo.service \
+ "
+
+do_install() {
+ # Map viewer demo
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${WORKDIR}/switch_off_${PN}.sh ${D}/usr/AGL/${PN}
+ install -m 0755 ${WORKDIR}/switch_on_${PN}.sh ${D}/usr/AGL/${PN}
+
+ install -d ${D}${sysconfdir}/xdg/weston
+ install -m 0644 ${WORKDIR}/weston-${PN}.ini ${D}${sysconfdir}/xdg/weston/weston-${PN}.ini
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/weston-mapviewer-demo.service ${D}${systemd_system_unitdir}
+}
+
+## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
+##
+## The 'weston-mapviewer-demo.service' is exclusive of default 'weston.ini',
+## it should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
+##
+#SYSTEMD_SERVICE_${PN} = "weston-mapviewer-demo.service"
+
+FILES_${PN} += " \
+ ${systemd_system_unitdir} \
+ /usr/AGL/${PN}/ \
+ ${sysconfdir}/xdg/weston/${PN} \
+ "