summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer-demo.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-08-30 14:18:23 -0400
committerScott Murray <scott.murray@konsulko.com>2019-09-02 15:00:55 +0000
commitf19f2f6572adf3825e60ceb5e18e3e35d1995bec (patch)
tree780b84b6f18440838cadae532904374b8352ada5 /recipes-demo-hmi/navigation/mapviewer-demo.bb
parent80f21c014fc13dbd624e3ed6346b3d991615e28c (diff)
Update demo features for switch to ondemandnavihalibut_8.0.1halibut/8.0.18.0.1
The ondemandnavi navigation application does not work with the mapviewer cluster demo application, so update the logic to handle the agl-cluster-demo-support feature in packagegroup-agl-demo-platform to not pull it in when using ondemandnavi as the virtual/navigation provider. Since the plan is to replace mapviewer with an equivalent QtLocation based map streamer for the cluster demo, the mapviewer-demo recipe has also been replaced with a more generically named cluster-demo-network-config recipe. Additionally, the agl-demo-preload feature logic has been tweaked to not pull in the map package for the old navigation application when using ondemandnavi. Bug-AGL: SPEC-2576 Change-Id: I57b45ab152f9fab6cee97d570be1949136cd39eb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer-demo.bb')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo.bb b/recipes-demo-hmi/navigation/mapviewer-demo.bb
deleted file mode 100644
index 44f48049..00000000
--- a/recipes-demo-hmi/navigation/mapviewer-demo.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "Setting files of mapviewer for the AGL Demonstrator"
-DESCRIPTION = "Setting files of mapviewer for the AGL Demonstrator"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SECTION = "apps"
-
-inherit systemd
-
-SRC_URI = " \
- file://weston-ready.conf \
- file://mapviewer-demo-network-conf.service \
-"
-
-do_install() {
- # Install cluster demo network configuration service unit
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/mapviewer-demo-network-conf.service ${D}${systemd_system_unitdir}
-
- # Add symlink to network.target.wants
- install -d ${D}${sysconfdir}/systemd/system/network.target.wants
- ln -s ${systemd_system_unitdir}/mapviewer-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
-
- # Workaround for now to ensure that the windowmanager and its dependencies
- # start after weston, which takes longer with gst-record enabled.
- # This should be investigated a bit further and likely reworked into
- # something more generically applicable.
- install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
- install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/ \
- ${systemd_system_unitdir} \
-"