summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-demo-hmi/navigation
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-demo-hmi/navigation')
-rw-r--r--recipes-demo-hmi/navigation/navigation-demo_git.bb32
-rw-r--r--recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini9
-rw-r--r--recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb21
-rw-r--r--recipes-demo-hmi/navigation/ondemandnavi_git.bb33
-rw-r--r--recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb21
-rw-r--r--recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch21
-rw-r--r--recipes-demo-hmi/navigation/poiapp_git.bb21
-rw-r--r--recipes-demo-hmi/navigation/tbtnavi_git.bb36
8 files changed, 0 insertions, 194 deletions
diff --git a/recipes-demo-hmi/navigation/navigation-demo_git.bb b/recipes-demo-hmi/navigation/navigation-demo_git.bb
deleted file mode 100644
index 7f3fcdf1..00000000
--- a/recipes-demo-hmi/navigation/navigation-demo_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SUMMARY = "Navigation demo based on Qt examples"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/navigation"
-SECTION = "apps"
-
-LICENSE = "BSD-3-Clause & CC0v1"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b6bbd37d85cd2b68082aa7be27853da1 \
- file://LICENSE.for_car_png;md5=65d3616852dbf7b1a6d4b53b00626032 \
- "
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/navigation;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-RPROVIDES_${PN} = "virtual/navigation"
-
-DEPENDS += "qtquickcontrols2 \
- libhomescreen \
- qtvirtualkeyboard \
- qtlocation \
- "
-
-RDEPENDS_${PN} = " \
- agl-service-gps \
- agl-service-geoclue \
- agl-service-geofence \
- qtlocation \
- qtvirtualkeyboard \
- "
-
-inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini b/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini
deleted file mode 100644
index 356c6ae6..00000000
--- a/recipes-demo-hmi/navigation/ondemandnavi-config/naviconfig.ini
+++ /dev/null
@@ -1,9 +0,0 @@
-{
- "mapAccessToken":"MAPBOX_ACCESS_TOKEN",
- "speed":60,
- "interval":100,
- "latitude":36.1363,
- "longitude":-115.151,
- "mapStyleUrls":"mapbox://styles/v1/mapbox/streets-v11",
- "enableOSM":true
-}
diff --git a/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb b/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb
deleted file mode 100644
index 212971f2..00000000
--- a/recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference On Demand Navigation application config."
-DESCRIPTION = "Config file for on-demand navigation app."
-HOMEPAGE = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
-SECTION = "apps"
-LICENSE = "Proprietary"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-SRC_URI = "file://naviconfig.ini \
- "
-
-inherit allarch
-
-MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
-
-do_compile[noexec] = "1"
-
-do_install () {
- install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
- sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
-}
diff --git a/recipes-demo-hmi/navigation/ondemandnavi_git.bb b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
deleted file mode 100644
index c06dcae2..00000000
--- a/recipes-demo-hmi/navigation/ondemandnavi_git.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "AGL Reference On Demand Navigation application."
-DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS += "qtquickcontrols2 \
- qlibhomescreen \
- qtlocation \
- libqtappfw \
-"
-
-PV = "1.0+git${SRCPV}"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 aglwgt pkgconfig
-
-RDEPENDS_${PN} += "qtlocation \
- flite \
- libqtappfw \
- openjtalk \
- gstreamer1.0 \
- ondemandnavi-config \
-"
-
-RPROVIDES_${PN} = "virtual/navigation"
-
diff --git a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
deleted file mode 100644
index d353d7dd..00000000
--- a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference POI application API key."
-DESCRIPTION = "Preload the API key for the AGL POI application."
-HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
-SECTION = "apps"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-inherit allarch
-
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_compile[noexec] = "1"
-
-POIAPP_CLIENT_ID ?= ""
-POIAPP_API_KEY ?= ""
-
-do_install () {
- install -d ${D}${sysconfdir}
- echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
- echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
-}
diff --git a/recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch b/recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch
deleted file mode 100644
index 25a8fc31..00000000
--- a/recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Add display permission
-
-Add display permission required to work with the running as non-root
-change for applications.
-
-Upstream-Status: pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/config.xml.in b/config.xml.in
-index b8cfccd..bec206d 100755
---- a/config.xml.in
-+++ b/config.xml.in
-@@ -13,6 +13,7 @@
- <feature name="urn:AGL:widget:required-permission">
- <param name="urn:AGL:permission::public:no-htdocs" value="required" />
- <param name="http://tizen.org/privilege/internal/dbus" value="required" />
-+ <param name="urn:AGL:permission::public:display" value="required" />
- </feature>
- <license>GPL</license>
- </widget>
diff --git a/recipes-demo-hmi/navigation/poiapp_git.bb b/recipes-demo-hmi/navigation/poiapp_git.bb
deleted file mode 100644
index 2942bf07..00000000
--- a/recipes-demo-hmi/navigation/poiapp_git.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference POI application."
-DESCRIPTION = "This application provides the function of destination search to AGL. It uses the API provided by AGL Reference Navigation. This application uses yelp WebAPI."
-HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
-SECTION = "apps"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
-
-DEPENDS += "qtbase json-c \
- libhomescreen \
- libqtappfw \
- "
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-S = "${WORKDIR}/git"
-
-inherit cmake_qt5 pkgconfig aglwgt
-
-RDEPENDS_${PN} = "qtbase libqtappfw"
diff --git a/recipes-demo-hmi/navigation/tbtnavi_git.bb b/recipes-demo-hmi/navigation/tbtnavi_git.bb
deleted file mode 100644
index d2e8e633..00000000
--- a/recipes-demo-hmi/navigation/tbtnavi_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "AGL Reference Navigation Cluster Streaming application"
-DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtLocation widget."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
- file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
- file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
- file://LICENSE.mapbox-variant;md5=79558839a9db3e807e4ae6f8cd100c1c \
- file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
-"
-
-DEPENDS += "qtbase \
- qtquickcontrols2 \
- qlibhomescreen \
- qtlocation \
- libqtappfw \
- wayland-native \
- qtwayland-native \
-"
-
-PV = "1.0+git${SRCPV}"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 aglwgt pkgconfig
-
-RDEPENDS_${PN} += "qtlocation \
- ondemandnavi-config \
- agl-service-navigation \
- libqtappfw \
-"