summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2019-06-10 18:57:42 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-10 19:34:36 +0000
commitb341690d2cf66dec6fed0c981bb91d9fdbd3050e (patch)
tree5208c042b3be42cb66a9cbc111d175d45a01f89c /recipes-demo-hmi/navigation
parentf1c9acb641af6555c438e887e4bbfc3567bcc5e3 (diff)
mapviewer: Upgrade to thud
mapviewer has link error. This error is same as navigation app at 5f5a1fb6ea4fd884040ef3175f478321651afeab in meta-agl-demo Then we apply the same patch file to mapviewer. Bug-AGL : SPEC-2420 Change-Id: Ibaad718ccd3995860294e2648e884af8ba3c01df Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Diffstat (limited to 'recipes-demo-hmi/navigation')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch31
-rwxr-xr-xrecipes-demo-hmi/navigation/mapviewer_git.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch b/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
new file mode 100644
index 00000000..9506ce11
--- /dev/null
+++ b/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
@@ -0,0 +1,31 @@
+gpsnavi: Fix compilation with OpenSSL 1.1
+
+Handle the ERR_load_crypto_strings and ERR_free_strings functions no
+longer being present in OpenSSL 1.1.
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
+index eadab8f..2dfe1f3 100755
+--- a/src/sms/sms-core/SMCAL/SMCAL.c
++++ b/src/sms/sms-core/SMCAL/SMCAL.c
+@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
+ // 初期化
+ ERR_load_BIO_strings();
+ SSL_load_error_strings();
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ ERR_load_crypto_strings();
++#endif
+ OpenSSL_add_all_algorithms();
+
+ // SSLの初期化(戻り値は常に1)
+@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
+ if (NULL != cal->ssl.ctx) {
+ SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);
+ }
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ ERR_free_strings();
++#endif
+
+ cal->ssl.ssl = NULL;
+ cal->ssl.ctx = NULL;
diff --git a/recipes-demo-hmi/navigation/mapviewer_git.bb b/recipes-demo-hmi/navigation/mapviewer_git.bb
index 06fea24f..1922e7f1 100755
--- a/recipes-demo-hmi/navigation/mapviewer_git.bb
+++ b/recipes-demo-hmi/navigation/mapviewer_git.bb
@@ -15,7 +15,9 @@ DEPENDS = " \
RDEPENDS_${PN} = " navigation "
SRCREV="2dfef5e9141ccb11f83d141c6a7dcbe0ecd49e84"
-SRC_URI="git://github.com/AGLExport/mapviwer.git"
+SRC_URI="git://github.com/AGLExport/mapviwer.git \
+ file://0002-openssl-1.1-fixes.patch \
+"
# To avoid C++ library link failure
SECURITY_CFLAGS = ""