summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2019-06-10 19:44:31 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-12 19:39:02 +0000
commitbe139825cc255c3f2c9bf58d839a0b67c1458ed9 (patch)
tree0ed7c74d55fe6bf3070885a09e02d8bd8dc73ebb /recipes-demo-hmi/navigation
parentb83519f09832930495582d2ec185095604f20ecd (diff)
mapviewer-demo: Delete unnecessary configuration from gst-recoder.
Bug-AGL : SPEC-2420 Change-Id: I5af1a5963352257600a191233fd3e5f4d59dfe2e Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Diffstat (limited to 'recipes-demo-hmi/navigation')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo.bb12
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.conf11
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.ini31
3 files changed, 2 insertions, 52 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo.bb b/recipes-demo-hmi/navigation/mapviewer-demo.bb
index 95910da7..44f48049 100644
--- a/recipes-demo-hmi/navigation/mapviewer-demo.bb
+++ b/recipes-demo-hmi/navigation/mapviewer-demo.bb
@@ -8,23 +8,15 @@ SECTION = "apps"
inherit systemd
SRC_URI = " \
- file://weston-mapviewer-demo.ini \
- file://weston-mapviewer-demo.conf \
file://weston-ready.conf \
file://mapviewer-demo-network-conf.service \
"
do_install() {
- # Install tweaked weston configuration
- install -d ${D}${sysconfdir}/xdg/weston
- install -m 0644 ${WORKDIR}/weston-${PN}.ini ${D}${sysconfdir}/xdg/weston/weston-${PN}.ini
-
- # Install weston service unit configuration over-ride drop-in
- install -d ${D}${systemd_system_unitdir}/weston.service.d
- install -m 0644 ${WORKDIR}/weston-mapviewer-demo.conf ${D}${systemd_system_unitdir}/weston.service.d
-
# Install cluster demo network configuration service unit
+ install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/mapviewer-demo-network-conf.service ${D}${systemd_system_unitdir}
+
# Add symlink to network.target.wants
install -d ${D}${sysconfdir}/systemd/system/network.target.wants
ln -s ${systemd_system_unitdir}/mapviewer-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.conf b/recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.conf
deleted file mode 100644
index 8bccffd2..00000000
--- a/recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.conf
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-# Add dependency on network, since the recorder feature requires it
-After=network.target
-Requires=network.target
-
-[Service]
-# GSM?
-ExecStartPre=/bin/sleep 2
-# Replace default ExecStart line with one that uses the cluster demo specific ini
-ExecStart=
-ExecStart=/usr/bin/weston --idle-time=0 --tty=1 --gst-record --config=weston-mapviewer-demo.ini --log=/run/platform/display/weston.log
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.ini b/recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.ini
deleted file mode 100644
index d003aff6..00000000
--- a/recipes-demo-hmi/navigation/mapviewer-demo/weston-mapviewer-demo.ini
+++ /dev/null
@@ -1,31 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-virtual=1
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-[media-ctl]
-device=/dev/media1
-gl-fallback=false
-
-[output]
-name=HDMI-A-1
-transform=270
-recorder=false
-
-[output]
-# Disable LVDS
-name=LVDS-1
-mode=off
-
-[output]
-name=virtual1
-mode=1920x1080@60
-recorder=true
-ip=192.168.20.99
-port=5005
-bitrate=300000
-crop=384x368@0x0