summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-16 20:51:25 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 21:10:18 +0000
commitd786abb46aa885898c61d08dc7d6b4564bea2b93 (patch)
treedf79efe71c081a5911dac8d98c7cb26950d987dd /recipes-demo-hmi/navigation
parentd83abd39742aa01cab3db251ca28fab2306c764a (diff)
poiapp-api-key: Add client ID
Somehow in my original testing the POI app was working even though the client ID was not being added to /etc/poikey as the first line. Add a POIAPP_CLIENT_ID variable to go with POIAPP_API_KEY, and write them both to the file. As well, mark the package as platform independent, as it contains just a text configuration file. Change-Id: Iab5d6aa44007c61457697882d9a2ece12f984acf Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/navigation')
-rwxr-xr-xrecipes-demo-hmi/navigation/poiapp-api-key_1.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
index ad6546fe..4d53fdbf 100755
--- a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
+++ b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
@@ -9,9 +9,13 @@ do_fetch[noexec] = "1"
do_unpack[noexec] = "1"
do_compile[noexec] = "1"
+POIAPP_CLIENT_ID ?= ""
POIAPP_API_KEY ?= ""
do_install () {
install -d ${D}${sysconfdir}
- echo "${POIAPP_API_KEY}" > ${D}${sysconfdir}/poikey
+ echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
+ echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
}
+
+PACKAGE_ARCH = "all"