summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/radio
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-demo-hmi/radio
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-demo-hmi/radio')
-rw-r--r--recipes-demo-hmi/radio/files/presets-ALS.conf12
-rw-r--r--recipes-demo-hmi/radio/files/presets-CES.conf14
-rw-r--r--recipes-demo-hmi/radio/files/presets-FOSDEM.conf14
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb37
4 files changed, 0 insertions, 77 deletions
diff --git a/recipes-demo-hmi/radio/files/presets-ALS.conf b/recipes-demo-hmi/radio/files/presets-ALS.conf
deleted file mode 100644
index ff559227..00000000
--- a/recipes-demo-hmi/radio/files/presets-ALS.conf
+++ /dev/null
@@ -1,12 +0,0 @@
-[fmPresets]
-1\frequency=76100000
-1\title=Inter FM
-2\frequency=77100000
-2\title=The Open University of Japan
-3\frequency=80000000
-3\title=TOKYO FM
-4\frequency=81300000
-4\title=J-WAVE
-5\frequency=82500000
-5\title=NHK FM Tokyo
-size=5
diff --git a/recipes-demo-hmi/radio/files/presets-CES.conf b/recipes-demo-hmi/radio/files/presets-CES.conf
deleted file mode 100644
index 83caeffe..00000000
--- a/recipes-demo-hmi/radio/files/presets-CES.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-[fmPresets]
-1\frequency=93100000
-1\title=93.1 The Mountain
-2\frequency=94100000
-2\title=Mix 94.1
-3\frequency=96300000
-3\title=96.3 KKLZ
-4\frequency=102700000
-4\title=102.7 THE COYOTE
-5\frequency=88900000
-5\title=News 88.9
-6\frequency=91500000
-6\title=KUNV
-size=6
diff --git a/recipes-demo-hmi/radio/files/presets-FOSDEM.conf b/recipes-demo-hmi/radio/files/presets-FOSDEM.conf
deleted file mode 100644
index b88364f7..00000000
--- a/recipes-demo-hmi/radio/files/presets-FOSDEM.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-[fmPresets]
-1\frequency=92100000
-1\title=92.1 Radio Campus
-2\frequency=92500000
-2\title=92.5 RTBF La Première
-3\frequency=93200000
-3\title=93.2 RTBF Classic 21
-4\frequency=98800000
-4\title=98.8 FM Brussel
-5\frequency=103700000
-5\title=103.7 NRJ
-6\frequency=104000000
-6\title=104.0 Bel RTL
-size=6
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
deleted file mode 100644
index 7b0934fa..00000000
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SUMMARY = "Radio for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0 & GPLv2+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;branch=${AGL_BRANCH} \
- file://presets-ALS.conf \
- file://presets-CES.conf \
- file://presets-FOSDEM.conf \
-"
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-# build-time dependencies
-DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "libhomescreen libqtappfw"
-
-inherit qmake5 aglwgt
-
-# ALS, CES, FOSDEM available
-AGL_RADIO_PRESETS_LOCALE ?= "CES"
-do_install_append() {
- install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
-}
-
-FILES_${PN} += "${sysconfdir}/xdg/AGL/*"
-
-RDEPENDS_${PN} += "agl-service-radio libqtappfw"