summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/radio
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-08-18 03:50:45 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-04 22:16:15 +0000
commitc8876ab96c70793b2617534d79cd7f27bfbbb398 (patch)
treefef606f5de963590bd64b6a5d453039c0f2d3fcc /recipes-demo-hmi/radio
parent981760a5075e6d36994cd37acaa78b84eba71e56 (diff)
agl-service-radio: add recipe for newly standalone binding
Now that the radio binding is standalone their needs to be a recipe to build it, and a RDEPENDS added to the radio application. Bug-AGL: SPEC-834 Change-Id: I1d830181c6dcd12036b8e39d0442e010d579194e Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/radio')
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
index ca75f2d7..41e78d35 100644
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -18,7 +18,7 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS = "qtquickcontrols2 rtl-sdr glib-2.0 pulseaudio alsa-lib"
+DEPENDS = "qtquickcontrols2"
inherit qmake5 aglwgt
@@ -37,3 +37,5 @@ FILES_${PN} += " \
/home/root/app-data/radio/presets-*.conf \
/home/root/app-data/radio/presets.conf \
"
+
+RDEPENDS_${PN} += "agl-service-radio"