summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/radio
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-22 10:39:00 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 14:15:09 +0000
commitd312c2fb6f0a00f3abb45e99d4085845715866c7 (patch)
tree503feef1ac04140825b7c233b2697208ad8bf992 /recipes-demo-hmi/radio
parent64b28dd3f4004a6c651b96513820e39f6d0b8c69 (diff)
Use ROOT_HOME variable, not /home/root
This enforces the use of the dedicated variable ROOT_HOME of yocto instead of /home/root. Note that the use of root's home made in the patched demos is bad and have to be changed. Change-Id: Ib0095a62d75800a0427be27955d1b2216b14554f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'recipes-demo-hmi/radio')
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
index 8563b018..4f8063a0 100644
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -27,16 +27,16 @@ inherit qmake5 aglwgt
AGL_RADIO_PRESETS_LOCALE ?= "CES"
do_install_append() {
- install -d ${D}/home/root/app-data/radio
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
+ install -d ${D}${ROOT_HOME}/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${ROOT_HOME}/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${ROOT_HOME}/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${ROOT_HOME}/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${ROOT_HOME}/app-data/radio/presets.conf
}
FILES_${PN} += " \
- /home/root/app-data/radio/presets-*.conf \
- /home/root/app-data/radio/presets.conf \
+ ${ROOT_HOME}/app-data/radio/presets-*.conf \
+ ${ROOT_HOME}/app-data/radio/presets.conf \
"
RDEPENDS_${PN} += "agl-service-radio"