summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/vod-server/vod-server_0.1.bb
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-12-14 14:25:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-17 17:27:34 +0000
commitb092df77e7b5ede496f4d3c8b71ba37a640b1fa8 (patch)
tree0d506831862e96a8bc01d281c857a47c27bef2ab /recipes-demo-hmi/vod-server/vod-server_0.1.bb
parentbd3ecfb968fa756604f444692d4d7d9bdd62acdf (diff)
recipes-demo-hmi: add recipes to build MOST applications
This patch adds the recipes to build the recently pushed sources for the MostNetworkManager, the VideoOnDemand server. Additionally, it updates the recipe to fetch the CAN/LIN binary. Change-Id: I77d5727d9b2b9b6f93ee959cf9b828090c35d05a Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-demo-hmi/vod-server/vod-server_0.1.bb')
-rw-r--r--recipes-demo-hmi/vod-server/vod-server_0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
new file mode 100644
index 00000000..949509d6
--- /dev/null
+++ b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Build VideoOnDemand server"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+# "
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
+
+S = "${WORKDIR}/git"
+#SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
+SRCREV = "${AUTOREV}"
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+}
+