summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/vod-server/vod-server_0.1.bb
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-22 10:39:00 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 14:15:09 +0000
commitd312c2fb6f0a00f3abb45e99d4085845715866c7 (patch)
tree503feef1ac04140825b7c233b2697208ad8bf992 /recipes-demo-hmi/vod-server/vod-server_0.1.bb
parent64b28dd3f4004a6c651b96513820e39f6d0b8c69 (diff)
Use ROOT_HOME variable, not /home/root
This enforces the use of the dedicated variable ROOT_HOME of yocto instead of /home/root. Note that the use of root's home made in the patched demos is bad and have to be changed. Change-Id: Ib0095a62d75800a0427be27955d1b2216b14554f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'recipes-demo-hmi/vod-server/vod-server_0.1.bb')
-rw-r--r--recipes-demo-hmi/vod-server/vod-server_0.1.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
index 73b7fb74..5c3ad6a6 100644
--- a/recipes-demo-hmi/vod-server/vod-server_0.1.bb
+++ b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -24,12 +24,13 @@ do_install() {
# Execute install manually for root user on behalf of systemctl script
# because it doesn't support user mode of systemd.
- install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
- ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ sed -i "s:/home/root:${ROOT_HOME}:" ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
fi
}
FILES_${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
"