summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/vod-server
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-21 16:26:19 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-21 13:01:44 +0000
commit748f48cbe6914c9eb48832ab8bd504bbccc418a3 (patch)
treed5eefcbc6b241a5d20d5bc2325fc890fb0615a37 /recipes-demo-hmi/vod-server
parent30a56b507d8e924380b1d248e939d10096b21ce7 (diff)
Add systemd service for VOD demo setup
This change is for booting all stuff of VOD service demo for RSE automatically after MOST network manager. Change-Id: Ia985d0c6a1dad8a6cad201205141152435318b59 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-demo-hmi/vod-server')
-rw-r--r--recipes-demo-hmi/vod-server/files/vod-demo.service10
-rw-r--r--recipes-demo-hmi/vod-server/vod-server_0.1.bb21
2 files changed, 28 insertions, 3 deletions
diff --git a/recipes-demo-hmi/vod-server/files/vod-demo.service b/recipes-demo-hmi/vod-server/files/vod-demo.service
new file mode 100644
index 00000000..c783bd4a
--- /dev/null
+++ b/recipes-demo-hmi/vod-server/files/vod-demo.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Video On Demand AGL Demo
+After=WindowManager.service most-network-manager.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/VideoOnDemand -p /home/root/Video
+
+[Install]
+WantedBy=default.target
diff --git a/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
index 949509d6..3d724bdf 100644
--- a/recipes-demo-hmi/vod-server/vod-server_0.1.bb
+++ b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -7,14 +7,29 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
PV = "0.1"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
-SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
+ file://vod-demo.service"
S = "${WORKDIR}/git"
#SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
SRCREV = "${AUTOREV}"
do_install() {
- install -m 0755 -d ${D}${bindir}
- install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+ install -m 0755 -d ${D}${bindir}
+ install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+
+ # Install VOD server systemd service (user)
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -m 644 -p -D ${WORKDIR}/vod-demo.service ${D}${systemd_user_unitdir}/vod-demo.service
+
+ # Execute install manually for root user on behalf of systemctl script
+ # because it doesn't support user mode of systemd.
+ install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
+ fi
}
+FILES_${PN} += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+ "