summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-09-08 10:26:03 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-08 15:51:55 +0000
commit13109053397fd99ad6ce38f9a2edc4e9fc6e009f (patch)
treea8afe6c662b743846c3865fd869f147483d3a53c /recipes-demo-hmi
parentc37ceb26f408455d8bfc964d7e8b0e81e903f7c9 (diff)
html5-homescreen: Avoid autostart of launcher on qemu
When launching automatically the html5-laucher from the html5-homescreen using the sw compositing pipeline on qemu, a race condition is happening that is breaking the UI. This is removing this autostart of the launcher, which still can be started manually, while the racing issues are fixed. Bug-AGL: SPEC-3544 Signed-off-by: Lorenzo Tilve <ltilve@igalia.com> Change-Id: Ic9e3dbf68d69d3042b0e850e63c7ff0c210cf1a4
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch25
-rw-r--r--recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb3
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch b/recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch
new file mode 100644
index 00000000..6a8efd70
--- /dev/null
+++ b/recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch
@@ -0,0 +1,25 @@
+From 5112f934e4e5afca02467088d3c7008cbdc620d2 Mon Sep 17 00:00:00 2001
+From: Lorenzo Tilve <ltilve@igalia.com>
+Date: Mon, 7 Sep 2020 06:53:52 +0200
+Subject: [PATCH] Disable autostart of launcher webapp
+
+Change-Id: I2eabab3772e4e5eb457f2c47670448554e72d14a
+---
+ src/config.json | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/config.json b/src/config.json
+index fb94d9d..febbb21 100644
+--- a/src/config.json
++++ b/src/config.json
+@@ -18,7 +18,6 @@
+ }
+ ],
+ "background": "webapps-html5-background",
+- "launch": "webapps-html5-launcher",
+ "network": {
+ "bluetooth": "fab fa-bluetooth-b",
+ "ethernet": "fas fa-network-wired",
+--
+2.28.0
+
diff --git a/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
index 37ca7073..a44f72f4 100644
--- a/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
@@ -8,6 +8,9 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
+
+SRC_URI_append_qemuall = " file://0001-Disable-autostart-of-launcher-webapp.patch"
+
SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"