summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-06 19:00:44 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 14:57:00 +0000
commit383abf8322acf90fbb56551eb8eefaef1854d8d4 (patch)
tree29c3a07f4ddcdee489d7e9154018c93f42ac1131 /recipes-demo-hmi
parent37ef25bb36711114fd379e74ab18737e0224c364 (diff)
html5-mixer: create recipe and add to html5 demo
Bug-AGL: SPEC-2824 Change-Id: Icc15a48d2a78dfdd57bf60f050ec0b66c714aefa Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/html5-mixer/html5-mixer_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
new file mode 100644
index 00000000..babef57c
--- /dev/null
+++ b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Mixer Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mixer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}