summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-29 18:51:16 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-30 14:59:45 +0000
commit80d8e80fb02a5667c279ef492b778169fd9c5066 (patch)
treecbe5d9cf0c1771c4b55c2c1647aad986ee650324 /recipes-demo-hmi
parent0c284fb6273dc039c1573e2f6681e9c56708d0f1 (diff)
Add qt-qrcode recipe for use in settings app
Add a recipe for the qt-qrcode libqrencode wrapper library to allow using it to display QR codes in the settings app, and update the settings app dependencies to add it as a dependency. As cleanup, the qtwebsockets dependency has been dropped from settings since it no longer requires it. Bug-AGL: SPEC-2981 Change-Id: Ia0d40ea1151765fa967457bf2ab6624dc7bc259d Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/settings/settings_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-demo-hmi/settings/settings_git.bb b/recipes-demo-hmi/settings/settings_git.bb
index 36040823..72e0323f 100644
--- a/recipes-demo-hmi/settings/settings_git.bb
+++ b/recipes-demo-hmi/settings/settings_git.bb
@@ -13,12 +13,14 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets"
+DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
# runtime dependencies
RDEPENDS_${PN} += " \
- agl-service-bluetooth \
- agl-service-network"
+ qt-qrcode \
+ agl-service-bluetooth \
+ agl-service-network \
+"
inherit qmake5 aglwgt