summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-20 13:19:19 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-10-21 16:25:57 +0000
commita3275fc08f5c8808aec3c33895c57f3f45322f61 (patch)
tree662b44dc5b31770ea8f6ffc0c74fd1bc1c1258ce /recipes-demo-hmi
parent1d7fe07ecc136cc0da9b25f57c2f599044c92f4c (diff)
Add tbtnavi cluster navigation application
Add recipe for tbtnavi turn by turn navigation application for use on cluster remote display, and update packagegroup-agl-demo-platform to pull it in when PREFERRED_RPROVIDER_virtual/navigation is ondemandnavi (the default) and the agl-cluster-demo-support feature is enabled. Bug-AGL: SPEC-2913 Change-Id: I0280fe3a2fbd3ff58a028232560b421e83baa887 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/navigation/tbtnavi_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/tbtnavi_git.bb b/recipes-demo-hmi/navigation/tbtnavi_git.bb
new file mode 100644
index 00000000..88680ed9
--- /dev/null
+++ b/recipes-demo-hmi/navigation/tbtnavi_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "AGL Reference Navigation Cluster Streaming application"
+DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtLocation widget."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
+ file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
+ file://LICENSE.mapbox-variant;md5=79558839a9db3e807e4ae6f8cd100c1c \
+ file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
+"
+
+DEPENDS += "qtbase \
+ qtquickcontrols2 \
+ qlibhomescreen \
+ qlibwindowmanager \
+ qtlocation \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
+#SRCREV = "4a8b7a6301e4b093c99329d0a16fbee6c535f312"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 aglwgt pkgconfig
+
+RDEPENDS_${PN} += "qtlocation \
+ ondemandnavi-config \
+"