summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-20 17:58:48 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-20 22:55:55 +0000
commita6eebb7afd9da6bd12cda1a71cd207301252e914 (patch)
tree28ddc4d75f3db6480ee7836f05df33bdd40fad9c /recipes-demo-hmi
parent4cc407fdeba501019f8aa132c22072272792b948 (diff)
alexa-viewer: add recipe and conditionally add to demo image
Add recipe for demo voice capabilities GUI metadata event viewer for Alexa voiceagent, and conditionally add it to the list of applications in packagegroup-agl-demo-platform based on the agl-voiceagent-alexa feature being present in IMAGE_FEATURES. Bug-AGL: SPEC-3110 Change-Id: I7b84ace51430937dbcb35f4773b06290039a19bd Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
new file mode 100644
index 00000000..f98704ee
--- /dev/null
+++ b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Demo voice capabilities template viewer for Alexa voiceagent"
+DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+ qtquickcontrols2 \
+ qlibwindowmanager \
+ qlibhomescreen \
+ af-binder \
+ libqtappfw \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} = " \
+ libqtappfw \
+ libafbwsc \
+ qlibwindowmanager \
+ qlibhomescreen \
+ agl-service-voice-high-capabilities \
+"