summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-10-20 20:14:30 +0300
committerMarius Vlad <marius.vlad@collabora.com>2020-11-11 00:10:35 +0200
commitda9725a4bea1c7a94cbef7faa4bbe0bbb3bac408 (patch)
tree905d70a2747a0af8fcb5648a84b5a8fe7cffef14 /recipes-demo-hmi
parentc68863270427488bf4df5c9bb6822f2665924834 (diff)
waltham-receiver: Added waltham-receiver recipe
Bug-AGL: SPEC-3605 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I14009401162f22a597f2abd970ab9e6b681c08ed
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/waltham-receiver/waltham-receiver_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/waltham-receiver/waltham-receiver_git.bb b/recipes-demo-hmi/waltham-receiver/waltham-receiver_git.bb
new file mode 100644
index 00000000..20efc33f
--- /dev/null
+++ b/recipes-demo-hmi/waltham-receiver/waltham-receiver_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Waltham-receiver"
+DESCRIPTION = "Waltham-receiver is a demo application for testing out Waltham"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "waltham wayland wayland-native \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
+
+inherit cmake pkgconfig aglwgt
+
+RDEPENDS_${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+"