summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-03 11:46:50 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 14:56:33 +0000
commitfe36156821cea7b32a5ae439c9e0a166a65c4068 (patch)
tree7dc9b08b59f1a05a6ce4b589f71b3f5b45b01c29 /recipes-demo-hmi
parent43d99e9b85c4e92f0621c8d26f2443cd98982a41 (diff)
html5-settings: create recipe and add to html5 demo
Bug-AGL: SPEC-2823 Change-Id: Ia58ae3d871b1f5119daf60ea08378aba6fc75046 Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/html5-settings/html5-settings_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-settings/html5-settings_git.bb b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
new file mode 100644
index 00000000..dea1ec35
--- /dev/null
+++ b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Settings Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-settings/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}