summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-receiver
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-08-17 12:37:34 +0000
commit62c27830707e134dfe18662fb304c5905ead49af (patch)
tree776975c7a0eaf09b5ccdc4a0c8d8879d2dbd1a21 /recipes-demo/cluster-receiver
parentda95381c1a7f3ad1455cd0da8da48d34b187186b (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/cluster-receiver')
-rw-r--r--recipes-demo/cluster-receiver/cluster-receiver_git.bb2
-rw-r--r--recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-demo/cluster-receiver/cluster-receiver_git.bb b/recipes-demo/cluster-receiver/cluster-receiver_git.bb
index 70e660c57..ec701b387 100644
--- a/recipes-demo/cluster-receiver/cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/cluster-receiver_git.bb
@@ -26,7 +26,7 @@ inherit cmake pkgconfig systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
index e146a00d4..2dcc31cb5 100644
--- a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
@@ -27,7 +27,7 @@ inherit cmake_qt5 pkgconfig systemd
do_install:append() {
# Only install unit, do not enable it by default
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} += " \