summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-cluster-dashboard
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-30 14:12:49 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-31 15:10:54 +0000
commit61bdecebdc9990ad7e3f02697cbeeedfcde28461 (patch)
treed5cf63c30319585f84c69ddedb5b1367257c7c37 /recipes-demo/flutter-cluster-dashboard
parent70df8ec578574386a369fd83cb0b2162e461ee99 (diff)
flutter-cluster-dashboard: fix KVM demo configurationsHEADmaster
While reviewing things to document them, I realized thath the flutter-cluster-dashboard configuration for the plain KVM demo image was incorrect, and that a separate configuration was required for the preconfigured demo image where the databroker runs on the KVM host. This fixes the existing configuration file, adds a new one, and updates the corresponding preconfigured guest image. Bug-AGL: SPEC-5138 Change-Id: Ib24d3e1e5018efffce1bc820a7fd4f26ac38ddd6 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29926 ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/flutter-cluster-dashboard')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo2
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo-preconfigured4
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb9
3 files changed, 14 insertions, 1 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo
index 9267b4d4..17e5888e 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo
+++ b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo
@@ -1,4 +1,4 @@
-hostname: 172.16.10.1
+hostname: 172.16.10.2
authorization : "/etc/xdg/AGL/cluster-dashboard/cluster-dashboard.token"
use-tls : true
tls-server-name : "localhost"
diff --git a/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo-preconfigured b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo-preconfigured
new file mode 100644
index 00000000..9267b4d4
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.kvm-demo-preconfigured
@@ -0,0 +1,4 @@
+hostname: 172.16.10.1
+authorization : "/etc/xdg/AGL/cluster-dashboard/cluster-dashboard.token"
+use-tls : true
+tls-server-name : "localhost"
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index f3dd8f1e..b09156bb 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-clust
file://cluster-dashboard.yaml.demo \
file://cluster-dashboard.yaml.gateway-demo \
file://cluster-dashboard.yaml.kvm-demo \
+ file://cluster-dashboard.yaml.kvm-demo-preconfigured \
file://cluster-dashboard.token \
file://kvm.conf \
"
@@ -44,6 +45,7 @@ do_install:append() {
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.kvm-demo-preconfigured ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
@@ -85,3 +87,10 @@ RDEPENDS:${PN}-conf-kvm-demo = "${PN} ${PN}-conf-kvm"
RPROVIDES:${PN}-conf-kvm-demo = "cluster-dashboard.yaml"
ALTERNATIVE:${PN}-conf-kvm-demo = "cluster-dashboard.yaml"
ALTERNATIVE_TARGET_${PN}-conf-kvm-demo = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.kvm-demo"
+
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm-demo-preconfigured"
+FILES:${PN}-conf-kvm-demo-preconfigured += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.kvm-demo-preconfigured"
+RDEPENDS:${PN}-conf-kvm-demo-preconfigured = "${PN} ${PN}-conf-kvm"
+RPROVIDES:${PN}-conf-kvm-demo-preconfigured = "cluster-dashboard.yaml"
+ALTERNATIVE:${PN}-conf-kvm-demo-preconfigured = "cluster-dashboard.yaml"
+ALTERNATIVE_TARGET_${PN}-conf-kvm-demo-preconfigured = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.kvm-demo-preconfigured"