summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-dashboard
diff options
context:
space:
mode:
authorHritik Chouhan <hritikc3961@gmail.com>2022-08-10 22:27:34 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-07 16:24:43 +0000
commit062a9b29bc424ab4c9fdeebd65293be5bec074f6 (patch)
treee4e217ef5403d8972ae7544b291172778bf6c4cc /recipes-demo/flutter-dashboard
parentd84cb81e0012aded8d7e90f73e94a3eff9353148 (diff)
Add flutter dashboard app
- This adds the Flutter dashboard app in the AGL. - Pin the flutter dashboard app in IVI flutter demo homescreen. - Integrate with kuksa-val server. - change the homepage same as SRC_URI. - change the AGL_APP_NAME. Bug-AGL: SPEC-4524 Change-Id: I37dbcac2aa7a26b64250dd8fbec4de6051f16198 Signed-off-by: Hritik Chouhan <hritikc3961@gmail.com>
Diffstat (limited to 'recipes-demo/flutter-dashboard')
-rw-r--r--recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
new file mode 100644
index 00000000..822bb804
--- /dev/null
+++ b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Flutter Dashboard"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://github.com/hritik-chouhan/dashboard_for_recipe"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main"
+SRCREV = "c3234da907ff46fb113f308b5ab257089fdcab4f"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "dashboard_app"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "dashboard_app"
+AGL_APP_NAME = "Flutter Dashboard"