summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-dashboard
diff options
context:
space:
mode:
authorHritik Chouhan <hritikc3961@gmail.com>2022-09-10 20:35:16 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-22 10:35:44 +0000
commite252feedd4b3025ecdb71e2d3846e6e632b3e844 (patch)
tree8ce9d5e976bab2e0d53b522534468b64796f019c /recipes-demo/flutter-dashboard
parent8bab3bb3dd1d436bff0886b04b1df1261a0ae57c (diff)
Add recipes for flutter apps
- This add the flutter dashboard,hvac,navigation, mediaplayer apps in the AGL. - Pin all the flutter apps in IVI flutter demo homescreen. - Add config file for each app for kuksaAuthToken and mapboxAccessToken. Bug-AGL: SPEC-4560 Change-Id: If5f58e6ccc402f56fef66cc29d3959b834c4e27c Signed-off-by: Hritik Chouhan <hritikc3961@gmail.com>
Diffstat (limited to 'recipes-demo/flutter-dashboard')
-rw-r--r--recipes-demo/flutter-dashboard/files/dashboard_config.yaml3
-rw-r--r--recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb21
2 files changed, 22 insertions, 2 deletions
diff --git a/recipes-demo/flutter-dashboard/files/dashboard_config.yaml b/recipes-demo/flutter-dashboard/files/dashboard_config.yaml
new file mode 100644
index 00000000..6824c6b7
--- /dev/null
+++ b/recipes-demo/flutter-dashboard/files/dashboard_config.yaml
@@ -0,0 +1,3 @@
+hostname : localhost
+port : 8090
+kuskaAuthToken : eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJtb2RpZnlUcmVlIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.p2cnFGH16QoQ14l6ljPVKggFXZKmD-vrw8G6Vs6DvAokjsUG8FHh-F53cMsE-GDjyZH_1_CrlDCnbGlqjsFbgAylqA7IAJWp9_N6dL5p8DHZTwlZ4IV8L1CtCALs7XVqvcQKHCCzB63Y8PgVDCAqpQSRb79JPVD4pZwkBKpOknfEY5y9wfbswZiRKdgz7o61_oFnd-yywpse-23HD6v0htThVF1SuGL1PuvGJ8p334nt9bpkZO3gaTh1xVD_uJMwHzbuBCF33_f-I5QMZO6bVooXqGfe1zvl3nDrPEjq1aPulvtP8RgREYEqE6b2hB8jouTiC_WpE3qrdMw9sfWGFbm04qC-2Zjoa1yYSXoxmYd0SnliSYHAad9aXoEmFENezQV-of7sc-NX1-2nAXRAEhaqh0IRuJwB4_sG7SvQmnanwkz-sBYxKqkoFpOsZ6hblgPDOPYY2NAsZlYkjvAL2mpiInrsmY_GzGsfwPeAx31iozImX75rao8rm-XucAmCIkRlpBz6MYKCjQgyRz3UtZCJ2DYF4lKqTjphEAgclbYZ7KiCuTn9HualwtEmVzHHFneHMKl7KnRQk-9wjgiyQ5nlsVpCCblg6JKr9of4utuPO3cBvbjhB4_ueQ40cpWVOICcOLS7_w0i3pCq1ZKDEMrYDJfz87r2sU9kw1zeFQk
diff --git a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
index 822bb804..71d988db 100644
--- a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
+++ b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
@@ -11,10 +11,14 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main"
-SRCREV = "c3234da907ff46fb113f308b5ab257089fdcab4f"
+SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main \
+ file://dashboard_config.yaml \
+ "
+
+SRCREV = "5b0e5cdc3ba8b00a7e53b46e8b3e656cd09822bb"
S = "${WORKDIR}/git"
+
inherit agl-app flutter-app
# flutter-app
@@ -28,3 +32,16 @@ FLUTTER_BUILD_ARGS = "bundle -v"
AGL_APP_TEMPLATE = "agl-app-flutter"
AGL_APP_ID = "dashboard_app"
AGL_APP_NAME = "Flutter Dashboard"
+
+
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+
+
+
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL"
+