summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-hvac/flutter-hvac_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-09-21 14:32:53 -0400
committerScott Murray <scott.murray@konsulko.com>2023-09-22 15:44:58 +0000
commit0953c9e92ac9557b33712f91caf07780241bf3e3 (patch)
tree2c58603f0c3a31ff7d53c9f76c2f27ae54be3389 /recipes-demo/flutter-hvac/flutter-hvac_git.bb
parentd4d6744afb63b822a31c683b6510c54f7bcd74bf (diff)
flutter-hvac: update SRCREV
Update flutter-hvac SRCREV to pick up KUKSA.val databroker gRPC API changes, update its YAML configuration file to match, and add the JWT authorization token the configuration requires. Bug-AGL: SPEC-4762 Change-Id: If272680063afb3d286f1f709dcc59c40c58f858a Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29238 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/flutter-hvac/flutter-hvac_git.bb')
-rw-r--r--recipes-demo/flutter-hvac/flutter-hvac_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-demo/flutter-hvac/flutter-hvac_git.bb b/recipes-demo/flutter-hvac/flutter-hvac_git.bb
index d0305ce2..07f2cbbe 100644
--- a/recipes-demo/flutter-hvac/flutter-hvac_git.bb
+++ b/recipes-demo/flutter-hvac/flutter-hvac_git.bb
@@ -12,10 +12,11 @@ LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac;protocol=https;branch=${AGL_BRANCH} \
- file://HVAC_config.yaml \
+ file://hvac.yaml \
+ file://hvac.token \
"
-SRCREV = "20d76f947ef9d4a9093df0e5ad04476963655173"
+SRCREV = "6a853805d2479bf7b111511b1f94907e425c607a"
S = "${WORKDIR}/git"
inherit agl-app flutter-app
@@ -33,8 +34,9 @@ AGL_APP_ID = "flutter_hvac"
AGL_APP_NAME = "HVAC"
do_install:append() {
- install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/HVAC_config.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -d ${D}${sysconfdir}/xdg/AGL/hvac
+ install -m 0644 ${WORKDIR}/hvac.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
}
FILES:${PN} += "${sysconfdir}/xdg/AGL"