summaryrefslogtreecommitdiffstats
path: root/recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb')
-rw-r--r--recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb b/recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb
new file mode 100644
index 00000000..c3814f11
--- /dev/null
+++ b/recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb
@@ -0,0 +1,37 @@
+SUMMARY = "homescreen-demo-ci AGL client shell for testing in CI"
+DESCRIPTION = "homescreen-demo-ci AGL client shell for testing in CI"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "MIT"
+SECTION = "apps"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ agl-service-homescreen \
+ agl-service-weather \
+ libqtappfw \
+ libhomescreen \
+ libafb-helpers-qt \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen-demo-ci;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} += " \
+ libqtappfw \
+"