summaryrefslogtreecommitdiffstats
path: root/recipes-demo/homescreen/homescreen_git.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-demo/homescreen/homescreen_git.bb
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-demo/homescreen/homescreen_git.bb')
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb28
1 files changed, 13 insertions, 15 deletions
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index bf8034b9..b53519e9 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -4,40 +4,38 @@ HOMEPAGE = "http://docs.automotivelinux.org"
LICENSE = "Apache-2.0"
SECTION = "apps"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+#LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
DEPENDS = " \
qtbase \
qtdeclarative \
qtquickcontrols2 \
- libqtappfw \
- libhomescreen \
- libafb-helpers-qt \
wayland-native \
wayland \
qtwayland \
qtwayland-native \
agl-compositor \
+ json-c \
+ qtwebsockets \
"
PV = "1.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;nobranch=1"
+SRCREV = "09b5eb1b42910e84612a37a0fb44629c73eee3e7"
S = "${WORKDIR}/git"
-inherit qmake5 systemd pkgconfig aglwgt
+inherit qmake5 systemd pkgconfig
PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
-RDEPENDS:${PN} += " \
- libqtappfw \
- agl-service-audiomixer \
- agl-service-bluetooth \
- agl-service-homescreen \
- agl-service-network \
- agl-service-weather \
- agl-service-voice-high \
-"
+
+do_install:append() {
+
+ install -d ${D}/${bindir}
+ install -m 0644 ${B}/homescreen/HomeScreen ${D}/${bindir}/homescreen
+
+} \ No newline at end of file