summaryrefslogtreecommitdiffstats
path: root/recipes-demo/homescreen/homescreen_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-11-04 14:51:50 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-04 14:54:59 -0400
commit6adbf6b85fa629ec2ff43cd0a72f49b8020ddcb0 (patch)
treebd8cc2af8d4eabe1f919442d3ce9ad5bce413b38 /recipes-demo/homescreen/homescreen_git.bb
parent218fa1cb7fc71104cd12cd3af5576c17cd73643d (diff)
homescreen: update recipe
Rework homescreen demo app recipe for building a version of it with the application framework usage removed. A simple systemd unit to start it has been added as a placeholder until the new application scheme has been added. This will at least produce something on screen for testing, and the HOMESCREEN_DEMO_CI environment variable can be defined via /etc/default/homescreen to potentially re-enable the CI startup test. Bug-AGL: SPEC-4121 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I510873d428dc98286775722e23b34cd4a9862258
Diffstat (limited to 'recipes-demo/homescreen/homescreen_git.bb')
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb26
1 files changed, 15 insertions, 11 deletions
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index b53519e9..2b183d58 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -4,7 +4,6 @@ HOMEPAGE = "http://docs.automotivelinux.org"
LICENSE = "Apache-2.0"
SECTION = "apps"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-#LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
DEPENDS = " \
qtbase \
@@ -15,16 +14,16 @@ DEPENDS = " \
qtwayland \
qtwayland-native \
agl-compositor \
- json-c \
- qtwebsockets \
"
-PV = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;nobranch=1"
-SRCREV = "09b5eb1b42910e84612a37a0fb44629c73eee3e7"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+ file://homescreen.service \
+"
+SRCREV = "${AGL_APP_REVISION}"
-S = "${WORKDIR}/git"
+S = "${WORKDIR}/git"
inherit qmake5 systemd pkgconfig
@@ -32,10 +31,15 @@ PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
-
do_install:append() {
+ install -D -p -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+}
- install -d ${D}/${bindir}
- install -m 0644 ${B}/homescreen/HomeScreen ${D}/${bindir}/homescreen
+SYSTEMD_SERVICE_${PN} = "homescreen.service"
+SYSTEMD_AUTO_ENABLE = "enable"
-} \ No newline at end of file
+RDEPENDS:${PN} += " \
+ qtwayland \
+ qtbase-qmlplugins \
+ qtgraphicaleffects-qmlplugins \
+"