summaryrefslogtreecommitdiffstats
path: root/recipes-demo/launcher
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-10 13:11:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-21 13:18:47 +0000
commitab559762e86055ead1ffa2a5f93c91a4f743f9c4 (patch)
tree9036a8133bc33727a627c824c9935a733b1bdef9 /recipes-demo/launcher
parent56e0907b8ca1d7cbdd80f3805ef8d45a09f98aa1 (diff)
Switch Qt demo apps to gRPC launcher API
Changes: - Update SRCREV in libqtappfw, launcher, and homescreen recipes to pick up gRPC API changes. - Update libqtappfw recipe for switch to meson instead of CMake, and add new protobuf and gRPC dependencies. - Update launcher recipe to pull in new libqtappfw dependency, and update some formatting for consistency with the other recipes. Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6ec0f53a0cc68bcf9b434086d99e8849c11198f3
Diffstat (limited to 'recipes-demo/launcher')
-rw-r--r--recipes-demo/launcher/launcher_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
index 3c27fab9..96aa0efb 100644
--- a/recipes-demo/launcher/launcher_git.bb
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -9,7 +9,7 @@ DEPENDS = "\
qtbase \
qtdeclarative \
qtquickcontrols2 \
- qtwebsockets \
+ libqtappfw \
wayland-native \
wayland \
qtwayland \
@@ -19,15 +19,14 @@ DEPENDS = "\
applaunchd \
"
-PV = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
-SRC_URI = " \
- git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
- file://launcher.service \
- "
-SRCREV = "fd578508fe8f59a0bf11916ea99561125dcfc4ba"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
+ file://launcher.service \
+"
+SRCREV = "5e828161fc1571323e2812a344f6714ae9331b2c"
-S = "${WORKDIR}/git"
+S = "${WORKDIR}/git"
inherit qmake5 systemd pkgconfig
@@ -42,6 +41,7 @@ do_install:append() {
FILES:${PN} += " ${systemd_user_unitdir}"
RDEPENDS:${PN} += " \
+ libqtappfw \
applaunchd \
homescreen \
"