summaryrefslogtreecommitdiffstats
path: root/recipes-demo/videoplayer/videoplayer_git.bb
diff options
context:
space:
mode:
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>2022-07-29 14:29:32 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-22 11:20:22 +0000
commit7ff681b4eac52ffc83bc08145f1ae665db0b9a80 (patch)
tree47d6883be51ea9147d0d9f3e8387347b77aa59bc /recipes-demo/videoplayer/videoplayer_git.bb
parente252feedd4b3025ecdb71e2d3846e6e632b3e844 (diff)
recipes-demo: Add videoplayer recipe.
videoplayer BitBake recipe imported from attachment to AGL JIRA ticket [1] with adaptation for AGL NN. videoplayer suggested as an application to play video in [2]. Out from the box mediaplayer does not support video (only audio is supported). [1]: https://jira.automotivelinux.org/browse/SPEC-2389 [2]: https://jira.automotivelinux.org/browse/SPEC-4028 Bug-AGL: SPEC-4148 Change-Id: Ifd20f3e00ad1a99d0d05b8fb361ff7a8eb7a78f2 Signed-off-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Diffstat (limited to 'recipes-demo/videoplayer/videoplayer_git.bb')
-rw-r--r--recipes-demo/videoplayer/videoplayer_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-demo/videoplayer/videoplayer_git.bb b/recipes-demo/videoplayer/videoplayer_git.bb
new file mode 100644
index 00000000..36c83758
--- /dev/null
+++ b/recipes-demo/videoplayer/videoplayer_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Video Player for AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Media Player on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/videoplayer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/videoplayer;protocol=https;nobranch=1"
+SRCREV = "2f4d09aec6531c64356a52255bcfaf8df7c4f3e4"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += " \
+ qtquickcontrols2 \
+ libqtappfw \
+ qtmultimedia \
+"
+
+inherit qmake5 agl-app
+
+AGL_APP_NAME = "Video"
+
+RDEPENDS:${PN} += " \
+ qtmultimedia \
+ qtmultimedia-qmlplugins \
+"
+
+FILES:${PN} += "${datadir}/icons"