summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-05 10:08:59 -0400
committerScott Murray <scott.murray@konsulko.com>2023-06-07 13:33:53 -0400
commit2507e4a69862808a6331b0e4c665b694f49a49b9 (patch)
tree7031fe828a07407a21dcf82dd37fbd1774d5f6af /recipes-demo
parentcce52591f8e00ae41ae380a597d620b0856d004d (diff)
Remove systemd user session and clean up packagegroups and imagespike_15.91.0pike/15.91.015.91.0
Remove the use of systemd user session to align with how upstream runs Weston, and to allow using all systemd sandboxing features with the compositor and homescreen, launcher, etc. applications. The changes for this touched enough packagegroups and images that further rework was done to address some of the cleanup described in SPEC-4813, see below for details. Changes: - Rework systemd units and recipes of affected applications. - Rework images to pull in image .bb files instead of .inc files. - Pull in the new agl-image-compositor as a base image where appropriate. - Update weston-terminal-conf recipe to use new split out weston-terminal package. - Use new agl-crosssdk bbclass where appropriate. - Pull some local common cross-SDK additions into a new agl-ivi-crosssdk.inc include file and use as appropriate. Note that this does have a side effect of likely correcting the contents of agl-image-ivi-crosssdk for some recent additions. - Remove flutter-gallery bbappend that turned it into an app, as we are not using it in images, have other examples now, and it seems better to not affect the contents of agl-image-flutter. - Remove unused agl-image-graphical-html5. If a downstream user does desire an image with Chromium+WAM without applications, restoring it can be considered. - Remove unused agl-image-graphical-qt5-crosssdk. - Remove all packagegroup-agl-profile-* packagegroups, as they were either empty or not providing value at this point. Any future plans for defining profiles can start from a clean sheet. - Added new packagegroup-agl-ivi-multimedia-hardware to hold some rcar3 specific additions (via override) that were previously being appended onto packagegroup-agl-graphical-multimedia even though they are machine-specific and that packagegroup is not. This may be a stopgap solution if the agl-ivi-* packagegroups are reworked further. - Replace some :append usage with += to avoid creating problems for downstream users. Bug-AGL: SPEC-4714, SPEC-4813 Change-Id: I544b1495bed1e2e2412a8e46b7d20d7622ec28c9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service6
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb10
-rw-r--r--recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor.service3
-rw-r--r--recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb2
-rw-r--r--recipes-demo/cluster-receiver/cluster-receiver/cluster-receiver.service6
-rw-r--r--recipes-demo/cluster-receiver/cluster-receiver_git.bb10
-rw-r--r--recipes-demo/cluster-receiver/qt-cluster-receiver/qt-cluster-receiver.service6
-rw-r--r--recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb9
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service4
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb13
-rw-r--r--recipes-demo/flutter-gallery/flutter-gallery_agldemo.inc5
-rw-r--r--recipes-demo/flutter-gallery/flutter-gallery_git.bbappend1
-rw-r--r--recipes-demo/flutter-homescreen/files/flutter-homescreen.service4
-rw-r--r--recipes-demo/flutter-homescreen/flutter-homescreen_git.bb10
-rw-r--r--recipes-demo/homescreen/files/homescreen.service5
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb10
-rw-r--r--recipes-demo/html5-homescreen/files/homescreen.service4
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb38
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb2
-rw-r--r--recipes-demo/launcher/files/launcher.service4
-rw-r--r--recipes-demo/launcher/launcher_git.bb8
-rw-r--r--recipes-demo/navigation/tbtnavi/tbtnavi.service4
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb8
23 files changed, 88 insertions, 84 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
index d96c738b..de34e0a5 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
@@ -6,9 +6,11 @@ After=agl-compositor.service
# Since we are part of the agl session, make sure we are started before
# it is complete.
-Before=agl-session.target
+Before=graphical.target
[Service]
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/cluster-dashboard
Restart=always
@@ -17,4 +19,4 @@ StandardOutput=journal
StandardError=journal
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index dd463382..1404f671 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -26,14 +26,14 @@ SRCREV = "137144c447d8adb618f5acbcbafd65f50264d6eb"
S = "${WORKDIR}/git"
-inherit pkgconfig cmake_qt5
+inherit pkgconfig cmake_qt5 systemd
CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
do_install:append() {
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
- ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable
@@ -45,8 +45,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
qtwayland \
qtbase-qmlplugins \
diff --git a/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor.service b/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor.service
index cedad0e8..083a1e1f 100644
--- a/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor.service
+++ b/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor.service
@@ -2,7 +2,8 @@
Description=cluster-gauges-qtcompositor
[Service]
-Environment=XDG_RUNTIME_DIR=/run/user/0
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001
ExecStart=/usr/bin/cluster-gauges
Restart=always
diff --git a/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb b/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
index 166a504f..161e6652 100644
--- a/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
+++ b/recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
@@ -27,8 +27,6 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
qtquickcontrols \
qtquickcontrols-qmlplugins \
diff --git a/recipes-demo/cluster-receiver/cluster-receiver/cluster-receiver.service b/recipes-demo/cluster-receiver/cluster-receiver/cluster-receiver.service
index e544e25f..bf48afb2 100644
--- a/recipes-demo/cluster-receiver/cluster-receiver/cluster-receiver.service
+++ b/recipes-demo/cluster-receiver/cluster-receiver/cluster-receiver.service
@@ -6,9 +6,11 @@ After=agl-compositor.service
# Since we are part of the agl session, make sure we are started before
# it is complete.
-Before=agl-session.target
+Before=graphical.target
[Service]
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/xdg-cluster-receiver
Restart=always
@@ -17,4 +19,4 @@ StandardOutput=journal
StandardError=journal
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/cluster-receiver/cluster-receiver_git.bb b/recipes-demo/cluster-receiver/cluster-receiver_git.bb
index 59d19da1..c9842ff3 100644
--- a/recipes-demo/cluster-receiver/cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/cluster-receiver_git.bb
@@ -21,16 +21,14 @@ SRCREV = "ce90cf8dd26d596d65e222a94e64aa51e1c33298"
S = "${WORKDIR}/git"
-inherit cmake pkgconfig
+inherit cmake pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
gstreamer1.0-plugins-base \
gstreamer1.0-plugins-good \
diff --git a/recipes-demo/cluster-receiver/qt-cluster-receiver/qt-cluster-receiver.service b/recipes-demo/cluster-receiver/qt-cluster-receiver/qt-cluster-receiver.service
index bc328f9e..e3e1b952 100644
--- a/recipes-demo/cluster-receiver/qt-cluster-receiver/qt-cluster-receiver.service
+++ b/recipes-demo/cluster-receiver/qt-cluster-receiver/qt-cluster-receiver.service
@@ -6,9 +6,11 @@ After=agl-compositor.service
# Since we are part of the agl session, make sure we are started before
# it is complete.
-Before=agl-session.target
+Before=graphical.target
[Service]
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/qt-cluster-receiver
Restart=always
@@ -17,4 +19,4 @@ StandardOutput=journal
StandardError=journal
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
index 8d8908c2..d50e9dd1 100644
--- a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
@@ -23,18 +23,19 @@ SRCREV = "b5622ce91307589b03ad5d903214b47ff2277e48"
S = "${WORKDIR}/git"
-inherit cmake_qt5 pkgconfig
+inherit cmake_qt5 pkgconfig systemd
do_install:append() {
# Only install unit, do not enable it by default
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
qtwayland \
gstreamer1.0-plugins-base \
gstreamer1.0-plugins-good \
gstreamer1.0-plugins-bad \
"
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
index b79092e2..21082e7e 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
@@ -3,10 +3,12 @@ Requires=agl-compositor.service
After=agl-compositor.service
[Service]
+User=agl-driver
EnvironmentFile=/etc/default/flutter
EnvironmentFile=-/etc/default/flutter-cluster-dashboard
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/flutter_cluster_dashboard/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --j=/usr/share/flutter/flutter-cluster-dashboard.json
Restart=on-failure
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index b3076494..b7d9c4b6 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -26,16 +26,16 @@ FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
OPENROUTE_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
-inherit flutter-app update-alternatives
+inherit flutter-app update-alternatives systemd
CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
+SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
+
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
@@ -50,8 +50,9 @@ do_install:append() {
ALTERNATIVE_LINK_NAME[flutter-cluster-dashboard.yaml] = "${sysconfdir}/xdg/AGL/${BPN}.yaml"
-FILES:${PN} += "${datadir} ${systemd_user_unitdir} ${sysconfdir}/default/"
-RDEPENDS:${PN} += "flutter-auto agl-flutter-env"
+FILES:${PN} += "${datadir} ${sysconfdir}/default/"
+
+RDEPENDS:${PN} += "flutter-auto agl-flutter-env liberation-fonts"
PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-demo"
diff --git a/recipes-demo/flutter-gallery/flutter-gallery_agldemo.inc b/recipes-demo/flutter-gallery/flutter-gallery_agldemo.inc
deleted file mode 100644
index 4a7d3652..00000000
--- a/recipes-demo/flutter-gallery/flutter-gallery_agldemo.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-inherit agl-app
-
-AGL_APP_TEMPLATE = "agl-app-flutter"
-AGL_APP_ID = "gallery"
-AGL_APP_NAME = "Gallery"
diff --git a/recipes-demo/flutter-gallery/flutter-gallery_git.bbappend b/recipes-demo/flutter-gallery/flutter-gallery_git.bbappend
deleted file mode 100644
index 5e55224e..00000000
--- a/recipes-demo/flutter-gallery/flutter-gallery_git.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'flutter-gallery_agldemo.inc', '', d)}
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen.service b/recipes-demo/flutter-homescreen/files/flutter-homescreen.service
index a57fc5cc..6a1eabea 100644
--- a/recipes-demo/flutter-homescreen/files/flutter-homescreen.service
+++ b/recipes-demo/flutter-homescreen/files/flutter-homescreen.service
@@ -3,10 +3,12 @@ Requires=agl-compositor.service
After=agl-compositor.service
[Service]
+User=agl-driver
EnvironmentFile=/etc/default/flutter
EnvironmentFile=-/etc/default/flutter-homescreen
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/flutter_homescreen/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --j=/usr/share/flutter/flutter-homescreen.json --xdg-shell-app-id=homescreen
Restart=on-failure
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
index 0bd1ae19..62ea1e17 100644
--- a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
+++ b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
@@ -20,14 +20,14 @@ FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
FLUTTER_BUILD_ARGS = "bundle -v"
-inherit flutter-app
+inherit flutter-app systemd
APP_CONFIG = "${BPN}.json"
+SYSTEMD_SERVICE:${PN} = "flutter-homescreen.service"
+
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
@@ -35,5 +35,5 @@ do_install:append() {
install -m 0644 ${WORKDIR}/homescreen_config.yaml ${D}${sysconfdir}/xdg/AGL/
}
-FILES:${PN} += "${datadir} ${systemd_user_unitdir} ${sysconfdir}/xdg/AGL"
+FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
RDEPENDS:${PN} += "flutter-auto agl-flutter-env"
diff --git a/recipes-demo/homescreen/files/homescreen.service b/recipes-demo/homescreen/files/homescreen.service
index 7b765c7b..d35f52ad 100644
--- a/recipes-demo/homescreen/files/homescreen.service
+++ b/recipes-demo/homescreen/files/homescreen.service
@@ -1,12 +1,15 @@
[Unit]
Requires=agl-compositor.service
After=agl-compositor.service
+Before=graphical.target
[Service]
Type=simple
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
EnvironmentFile=-/etc/default/homescreen
ExecStart=/usr/bin/homescreen
Restart=on-failure
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index 7fbd55e0..e888dfca 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -29,16 +29,16 @@ SRCREV = "c9ae3bc5a102caad6d8040cd268a64295654e162"
S = "${WORKDIR}/git"
-inherit meson systemd pkgconfig
+inherit meson pkgconfig systemd
PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
do_install:append() {
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
- ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+ install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
# Currently using default global client and CA certificates
# for KUKSA.val SSL, installing app specific ones would go here.
@@ -52,8 +52,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
libqtappfw \
applaunchd \
diff --git a/recipes-demo/html5-homescreen/files/homescreen.service b/recipes-demo/html5-homescreen/files/homescreen.service
index b142c4ef..4cc44242 100644
--- a/recipes-demo/html5-homescreen/files/homescreen.service
+++ b/recipes-demo/html5-homescreen/files/homescreen.service
@@ -5,9 +5,11 @@ After=WebAppMgr.service dbus.service
[Service]
Type=simple
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStartPre=sleep 5
ExecStart=/usr/bin/WebAppMgr --appid=homescreen --app-install-dir=/usr/lib/wam_apps/html5-homescreen/
Restart=on-failure
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 463aa56d..c03aee49 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -4,42 +4,42 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
SRC_URI = " \
- git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
- file://homescreen.service \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
+ file://homescreen.service \
"
SRCREV = "e85c42ae77592afdb72df8e8d4f27e0e7ad17bb9"
-inherit pythonnative
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+inherit pythonnative systemd
DEPENDS = "nodejs-native"
do_compile[network] = "1"
do_compile() {
- cd ${S}
- rm -rf package node_modules package-lock.json
- npm install
- npm run build
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
+SYSTEMD_SERVICE:${PN} = "homescreen.service"
+
do_install() {
- install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
- cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
- ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -D -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
}
FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${systemd_user_unitdir} \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${systemd_system_unitdir} \
"
-RCONFLICTS:${PN} = "homescreen"
+RCONFLICTS:${PN} = "homescreen flutter-homescreen"
RDEPENDS:${PN} = "applaunchd html5-background"
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 71319fb6..f4f722fb 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -38,5 +38,5 @@ do_install() {
FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
-RCONFLICTS:${PN} = "launcher"
+RCONFLICTS:${PN} = "launcher flutter-homescreen"
RDEPENDS:${PN} = "applaunchd"
diff --git a/recipes-demo/launcher/files/launcher.service b/recipes-demo/launcher/files/launcher.service
index 7b3b172d..882d13a1 100644
--- a/recipes-demo/launcher/files/launcher.service
+++ b/recipes-demo/launcher/files/launcher.service
@@ -4,8 +4,10 @@ After=homescreen.service
[Service]
Type=simple
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/launcher
Restart=on-failure
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
index d9e959b5..c46a4a18 100644
--- a/recipes-demo/launcher/launcher_git.bb
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -32,14 +32,12 @@ inherit qmake5 systemd pkgconfig
PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
do_install:append() {
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
- ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+ install -D -m0644 ${WORKDIR}/launcher.service ${D}${systemd_system_unitdir}/launcher.service
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
libqtappfw \
applaunchd \
diff --git a/recipes-demo/navigation/tbtnavi/tbtnavi.service b/recipes-demo/navigation/tbtnavi/tbtnavi.service
index cc040009..fb77843c 100644
--- a/recipes-demo/navigation/tbtnavi/tbtnavi.service
+++ b/recipes-demo/navigation/tbtnavi/tbtnavi.service
@@ -4,8 +4,10 @@ After=agl-compositor.service
[Service]
Type=simple
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/tbtnavi
Restart=on-failure
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index 9da36827..22a87734 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -33,10 +33,10 @@ S = "${WORKDIR}/git"
inherit qmake5 systemd pkgconfig
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
do_install:append() {
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/tbtnavi.service ${D}${systemd_user_unitdir}/tbtnavi.service
- ln -s ../tbtnavi.service ${D}${systemd_user_unitdir}/agl-session.target.wants/tbtnavi.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
# Currently using default global client and CA certificates
# for KUKSA.val SSL, installing app specific ones would go here.
@@ -50,8 +50,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
qtlocation \
ondemandnavi-config \