summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorAakash Solanki <tech2aks@gmail.com>2022-09-02 11:55:26 +0200
committerAakash Solanki <tech2aks@gmail.com>2022-09-03 23:51:44 +0200
commit33d1ea369edc857634143f057109c252a66583af (patch)
tree9fb8f8a80606c4838347c4e99fe36c49f134252f /recipes-demo
parentf8eb43810177a33d2fb414341e31caa0ae75bdfe (diff)
Change SRCREV for flutter instrument cluster recipe
- Change SRCREV to use latest commit - Change packagename from `ic` to `flutter_cluster_dashboard` - Change kuksa_vss_init.py to add signals for navigation Latest commit of the flutter app includes the new navigation in the instrument cluster, more indicators and unnecessary files and folders are also removed. Bug-AGL: SPEC-4508 Change-Id: I766b410cd66774bfb84eeb0ce9654ed85e8d2af3 Signed-off-by: Aakash Solanki <tech2aks@gmail.com>
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json17
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json18
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json11
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json11
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json11
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json10
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb18
-rw-r--r--recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py13
8 files changed, 68 insertions, 41 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
new file mode 100644
index 00000000..3d92b45f
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
@@ -0,0 +1,17 @@
+{
+ "view": [
+ {
+ "window_type": "BG",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "vm_args": [
+ "--observatory-host",
+ "0.0.0.0",
+ "--observatory-port",
+ "1234"
+ ],
+ "width": 1920,
+ "height": 1080,
+ "fullscreen": true
+ }
+ ]
+} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
new file mode 100644
index 00000000..aca303fb
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
@@ -0,0 +1,18 @@
+{
+ "view": [
+ {
+ "window_type": "BG",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "vm_args": [
+ "--observatory-host",
+ "0.0.0.0",
+ "--observatory-port",
+ "1234",
+ "--start-paused"
+ ],
+ "width": 1920,
+ "height": 1080,
+ "fullscreen": true
+ }
+ ]
+} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
new file mode 100644
index 00000000..eb75dc4f
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
@@ -0,0 +1,11 @@
+{
+ "view": [
+ {
+ "window_type": "BG",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "width": 1920,
+ "height": 1080,
+ "fullscreen": true
+ }
+ ]
+} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json
deleted file mode 100644
index 3cee3508..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/ic",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json
deleted file mode 100644
index c7ea10fa..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/ic",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json
deleted file mode 100644
index fdff54f7..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/ic",
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 44be070f..4647f20b 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -8,27 +8,27 @@ SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
-SRC_URI = "git://github.com/aakash-s45/ic;protocol=https;branch=main \
+SRC_URI = "git://github.com/aakash-s45/ic;protocol=https;branch=master \
file://flutter-cluster-dashboard.service \
- file://ic_on_bg-debug.json \
- file://ic_on_bg-profile.json \
- file://ic_on_bg-release.json \
+ file://flutter_cluster_dashboard_on_bg-debug.json \
+ file://flutter_cluster_dashboard_on_bg-profile.json \
+ file://flutter_cluster_dashboard_on_bg-release.json \
"
PV = "1.0+git${SRCPV}"
-SRCREV = "32f72bb68142a0dbde9ccf28b27c445598c95112"
+SRCREV = "798851a33bb614fb1e5473a8046e63cd9b9026f4"
S = "${WORKDIR}/git"
-PUBSPEC_APPNAME = "ic"
+PUBSPEC_APPNAME = "flutter_cluster_dashboard"
FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
inherit flutter-app
-APP_CONFIG = "ic_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "ic_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "ic_on_bg-profile.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
+APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
+APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
do_install:append() {
diff --git a/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py b/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py
index 5453112c..0177e3c1 100644
--- a/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py
+++ b/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py
@@ -50,6 +50,12 @@ class VSS:
self.cruiseControlSpeedSet = "Vehicle.ADAS.CruiseControl.SpeedSet"
self.cruiseControlisActive = "Vehicle.ADAS.CruiseControl.IsActive"
self.batteryChargingStatus = "Vehicle.Powertrain.Battery.Charging.Status"
+ #
+ self.currLat = "Vehicle.Cabin.Infotainment.Navigation.CurrentLocation.Latitude"
+ self.currLng = "Vehicle.Cabin.Infotainment.Navigation.CurrentLocation.Longitude"
+ self.desLat = "Vehicle.Cabin.Infotainment.Navigation.DestinationSet.Latitude"
+ self.desLng = "Vehicle.Cabin.Infotainment.Navigation.DestinationSet.Longitude"
+ self.steeringInfo = "Vehicle.Cabin.SteeringWheel.Switches.Info"
def setInitialValues(self):
print("Setting values")
@@ -74,6 +80,13 @@ class VSS:
self.client.setValue(self.cruiseControlisActive, "false")
self.client.setValue(self.cruiseControlSpeedSet, '60')
self.client.setValue(self.batteryChargingStatus, "true")
+ #
+ self.client.setValue(self.currLat, "31.708643")
+ self.client.setValue(self.currLng, "76.931882")
+ self.client.setValue(self.desLat, "31.781456")
+ self.client.setValue(self.desLng, "76.997469")
+ # Show the map
+ self.client.setValue(self.steeringInfo, "true")
print("All value set succesfully")