summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-09-26 13:13:42 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-30 14:43:28 +0000
commit8bce79135715d04cb966fefaf8123d0dcb7ad435 (patch)
tree8c272373c8230bdbddbd8c9edf88d632745f4173 /recipes-demo
parentafca52385fa472f3c8bd0607865ed89a7d48c26d (diff)
Enable persistent storage API in Flutter IVI demoHEADmaster
Changes: - Bump flutter-ics-homescreen SRCREV to pick up the storage API changes. - Add a dependency on agl-persistent-storage-api to the homescreen systemd unit to ensure it will be started beforehand. - Add an environment file to be pulled in by the homescreen systemd unit that sets SPDLOG_LEVEL to enable debug output with latest flutter-auto. This should help with debugging any future issues. - Add agl-persistent-storage-api to the base Flutter IVI image. This gets it into the final demo image, and keeps the base Flutter IVI image (agl-image-ivi-flutter) usable for potentially working on the homescreen with the workspace-automation tooling. Bug-AGL: SPEC-5250 Change-Id: Icd2958a259f8eada8db0bfb99b47ba7a64094fa5 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30318 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.env1
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service4
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb7
3 files changed, 8 insertions, 4 deletions
diff --git a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.env b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.env
new file mode 100644
index 000000000..c85b7ed75
--- /dev/null
+++ b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.env
@@ -0,0 +1 @@
+SPDLOG_LEVEL=debug
diff --git a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service
index 421f87cda..be1acf52b 100644
--- a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service
+++ b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service
@@ -1,6 +1,6 @@
[Unit]
-Requires=agl-compositor.service applaunchd.service
-After=agl-compositor.service applaunchd.service
+Requires=agl-compositor.service applaunchd.service agl-persistent-storage-api.service
+After=agl-compositor.service applaunchd.service agl-persistent-storage-api.service
[Service]
User=agl-driver
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 0fa9c250b..5d78336a5 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;protocol=https;branch=${AGL_BRANCH} \
file://ics-homescreen.toml \
file://flutter-ics-homescreen.service \
+ file://flutter-ics-homescreen.env \
file://ics-homescreen.yaml \
file://ics-homescreen.yaml.gateway-demo \
file://ics-homescreen.yaml.kvm-demo \
@@ -17,7 +18,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
file://radio-presets.yaml \
file://kvm.conf \
"
-SRCREV = "d3ea8d7fa4518c258fca3c825ee895487fcaa8ec"
+SRCREV = "bdc33c218e3e62e5a3121d3ab0de6e26ef7ad3eb"
S = "${WORKDIR}/git"
@@ -39,6 +40,8 @@ APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.env ${D}${sysconfdir}/default/${BPN}
+
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
# VIS authorization token file for KUKSA.val should ideally not
@@ -56,7 +59,7 @@ do_install:append() {
ALTERNATIVE_LINK_NAME[ics-homescreen.yaml] = "${sysconfdir}/xdg/AGL/ics-homescreen.yaml"
-FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
+FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL ${sysconfdir}/default"
RDEPENDS:${PN} += " \
flutter-auto \