summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-05-20 13:15:57 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-26 20:59:58 +0000
commitb686aa6dc6a0fbd74ee421f1e0a94768b94a6528 (patch)
treec7e7b1a88094b24f4ffc8db3f03d4b727ee55b60 /recipes-demo
parenteee5b2e751961e4a72ab0f1783035099fe5240d1 (diff)
html5-*: allow network access to do_compile stage.
In our HTML5 demo packages, we use npm for retrieving dependencies, and that happens in compile stage. So network needs to be enabled accordingly. Bug-AGL: SPEC-4390 Change-Id: I6c00d83b611753d5e2d8d321aa3ad43898f81149 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/html5-background/html5-background_git.bb1
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb1
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb1
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb1
4 files changed, 4 insertions, 0 deletions
diff --git a/recipes-demo/html5-background/html5-background_git.bb b/recipes-demo/html5-background/html5-background_git.bb
index 24888fcc..1488f246 100644
--- a/recipes-demo/html5-background/html5-background_git.bb
+++ b/recipes-demo/html5-background/html5-background_git.bb
@@ -18,6 +18,7 @@ inherit pythonnative
DEPENDS = "nodejs-native"
+do_compile[network] = "1"
do_compile() {
cd ${S}
rm -rf package node_modules package-lock.json
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index cff6d473..db659760 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -18,6 +18,7 @@ inherit pythonnative
DEPENDS = "nodejs-native"
+do_compile[network] = "1"
do_compile() {
cd ${S}
rm -rf package node_modules package-lock.json
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 83b67451..7a1ecce5 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -18,6 +18,7 @@ inherit pythonnative
DEPENDS = "nodejs-native"
+do_compile[network] = "1"
do_compile() {
cd ${S}
rm -rf package node_modules package-lock.json
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 59087006..83e7f807 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -18,6 +18,7 @@ inherit pythonnative
DEPENDS = "nodejs-native"
+do_compile[network] = "1"
do_compile() {
cd ${S}
rm -rf package node_modules package-lock.json