summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-03-11 16:47:28 +0200
committerMarius Vlad <marius.vlad@collabora.com>2022-03-11 16:49:41 +0200
commitd5be36be695d8ec7f8f5de01cca432621ca8e01f (patch)
tree5c1b8c354949d577032c806a351ae1aadcde8312 /recipes-demo
parenta18da0f2c0a7b9982c03cef93672a8956cb111eb (diff)
html5-homescreen_git: Remove autobuild script builds
Bug-AGL: SPEC-4295 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Id819f3282d4b82ec985c94484cfe24a008e22106
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 1d5f14a4..0fdd02be 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"
do_compile() {
- bldcmd=${S}/autobuild/agl/autobuild
cd ${S}
- $bldcmd build
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
"
RCONFLICTS_${PN} = "homescreen"
-RDEPENDS_${PN} = "applaunchd html5-background" \ No newline at end of file
+RDEPENDS_${PN} = "applaunchd html5-background"