summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-devtools
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb17
-rw-r--r--recipes-devtools/python/python3-asyncssh_2.3.0.bb15
-rw-r--r--recipes-devtools/python/python3-pytest-dependency_0.5.1.bb12
-rw-r--r--recipes-devtools/python/python3-pytest-reverse_1.0.1.bb12
-rwxr-xr-xrecipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts48
-rw-r--r--recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service17
-rw-r--r--recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb46
-rw-r--r--recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bbappend1
8 files changed, 0 insertions, 168 deletions
diff --git a/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb b/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
deleted file mode 100644
index 4c0bda07..00000000
--- a/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Low level CAN generator"
-DESCRIPTION = "Generator used to customize low level CAN service with customs signals"
-SECTION = "devel"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit cmake pkgconfig
-BBCLASSEXTEND = "nativesdk"
-DEPENDS = " cmake-apps-module"
-
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/low-level-can-generator;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "0a3e354c3d81866e1a755367ab5592b3ced868bb"
-
-PV = "${AGLVERSION}"
-S = "${WORKDIR}/git"
-
diff --git a/recipes-devtools/python/python3-asyncssh_2.3.0.bb b/recipes-devtools/python/python3-asyncssh_2.3.0.bb
deleted file mode 100644
index f764b554..00000000
--- a/recipes-devtools/python/python3-asyncssh_2.3.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "\
-AsyncSSH is a Python package which provides an asynchronous client and \
-server implementation of the SSHv2 protocol on top of the Python \
-asyncio framework."
-HOMEPAGE = "https://github.com/ronf/asyncssh"
-LICENSE = "EPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
-
-SRC_URI[sha256sum] = "44bda34c7123f00c3df95d24e2dc8d43c4d17b456fbb8c434ef4f4a7ebb5265e"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += "${PYTHON_PN}-asyncio ${PYTHON_PN}-cryptography"
-
-BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb b/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
deleted file mode 100644
index 5ff2d4ec..00000000
--- a/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "pytest-dependency manages dependencies of tests."
-HOMEPAGE = "https://github.com/RKrahl/pytest-dependency"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://README.rst;md5=35b9938ae48d25e6b8306232e98463dd"
-
-SRC_URI[sha256sum] = "c2a892906192663f85030a6ab91304e508e546cddfe557d692d61ec57a1d946b"
-
-inherit pypi setuptools3
-
-DEPENDS += "${PYTHON_PN}-pytest-native"
-
-BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb b/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
deleted file mode 100644
index 5ed9b1d9..00000000
--- a/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "pytest-reverse is a pytest plugin to reverse test order"
-HOMEPAGE = "https://github.com/adamchainz/pytest-reverse"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=caf1f407ae86ecd57ab721dff94079b7"
-
-SRC_URI[sha256sum] = "40cbc47df8a262fed778e500f4d0b17d2d08ef8b9fbf899c0bab9488be192aac"
-
-inherit pypi setuptools3
-
-DEPENDS += "${PYTHON_PN}-pytest-native"
-
-BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts b/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
deleted file mode 100755
index 1d1a5a05..00000000
--- a/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/sh
-#
-# Copyright 2017 IoT.bzh.
-
-# Author: Ronan Le Martret <ronan.lemartret@iot.bzh>
-#
-
-# The following script will run all the scriptlets found in #SYSCONFDIR#/agl-postinsts.
-
-agl_pi_dir="#SYSCONFDIR#/agl-postinsts"
-
-POSTINST_LOGGING=1
-LOGFILE=/var/log/agl-postinstall.log
-
-[ -e $LOGFILE ] && mv ${LOGFILE} ${LOGFILE}.old.$(date +%F--%H%M.%S)
-
-append_log=">>$LOGFILE 2>&1"
-
-exec_postinst_scriptlets() {
- for i in `ls $agl_pi_dir`; do
- i=$agl_pi_dir/$i
- echo "Running postinst $i..."
- [ "$POSTINST_LOGGING" = "1" ] && eval echo "Running postinst $i..." $append_log
- if [ -x $i ]; then
- eval sh -c $i $append_log
- if [ $? -eq 0 ]; then
- rm $i
- else
- echo "ERROR: postinst $i failed."
- [ "$POSTINST_LOGGING" = "1" ] && eval echo "ERROR: postinst $i failed." $append_log
- remove_agl_pi_dir=0
- fi
- else
- echo "ERROR: postinst $i do not exists or do not have execute permission."
- [ "$POSTINST_LOGGING" = "1" ] && eval echo "ERROR: postinst $i do not exists or do not have execute permission." $append_log
- remove_agl_pi_dir=0
- fi
- done
-}
-
-remove_agl_pi_dir=1
-exec_postinst_scriptlets
-systemctl daemon-reload
-
-# since all postinstalls executed successfully, remove the postinstalls directory
-if [ $remove_agl_pi_dir = 1 ]; then
- rm -rf $agl_pi_dir
-fi
diff --git a/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service b/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
deleted file mode 100644
index 8f8667db..00000000
--- a/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
+++ /dev/null
@@ -1,17 +0,0 @@
-[Unit]
-Description=Run pending agl postinsts
-DefaultDependencies=no
-After=#SYSTEMD_SERVICE_AFTER#
-Before=#SYSTEMD_SERVICE_BEFORE#
-ConditionPathExists=#SYSCONFDIR#/agl-postinsts
-
-[Service]
-Type=oneshot
-StandardOutput=journal+console
-ExecStart=#SBINDIR#/run-agl-postinsts
-ExecStartPost=#BASE_BINDIR#/systemctl disable run-agl-postinsts.service
-RemainAfterExit=No
-TimeoutSec=0
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb b/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
deleted file mode 100644
index e7b91636..00000000
--- a/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-SUMMARY = "Runs AGL postinstall scripts on first boot of the target device"
-SECTION = "devel"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SRC_URI = "file://run-agl-postinsts \
- file://run-agl-postinsts.service"
-
-S = "${WORKDIR}"
-
-inherit allarch systemd
-
-SYSTEMD_SERVICE:${PN} = "run-agl-postinsts.service"
-
-SYSTEMD_SERVICE_AFTER ?= "dbus.service cynagora.service"
-
-SYSTEMD_SERVICE_BEFORE ?= "systemd-user-sessions.service"
-
-do_configure() {
- :
-}
-
-do_compile () {
- :
-}
-
-do_install() {
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/run-agl-postinsts ${D}${sbindir}/
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/run-agl-postinsts.service ${D}${systemd_unitdir}/system/
-
- sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
- -e 's:#SBINDIR#:${sbindir}:g' \
- -e 's:#BASE_BINDIR#:${base_bindir}:g' \
- -e 's:#LOCALSTATEDIR#:${localstatedir}:g' \
- ${D}${sbindir}/run-agl-postinsts \
- ${D}${systemd_unitdir}/system/run-agl-postinsts.service
-
- sed -i -e 's:#SYSTEMD_SERVICE_AFTER#:${SYSTEMD_SERVICE_AFTER}:g' \
- -e 's:#SYSTEMD_SERVICE_BEFORE#:${SYSTEMD_SERVICE_BEFORE}:g' \
- ${D}${systemd_unitdir}/system/run-agl-postinsts.service
-}
-
diff --git a/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bbappend b/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bbappend
deleted file mode 100644
index 32e3d6b8..00000000
--- a/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-SYSTEMD_SERVICE_AFTER:append = " afm-system-daemon.service"