summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-02-28 01:34:07 +0000
committerDenys Dmytriyenko <denys@konsulko.com>2023-02-28 01:34:07 +0000
commit321be58ab8a59195bf8557175cb7f4698e1144a6 (patch)
treef8eb05a2372fc3b7e9a20a18e9a1fca153665d28 /recipes-devtools
parenteaed764bc0a02029287d2531bedf13ce123641ee (diff)
python3-cantools: make bbappend changes conditional
Make bbappend changing RDEPENDS variable conditional on "agldemo" AGL_FEATURES flag. This resolved yocto-check-layer errors: INFO: test_signatures (common.CommonCheckLayer) INFO: ... FAIL AssertionError: Adding layer meta-agl-demo changed signatures, basehash changed Bug-AGL: SPEC-4685 Change-Id: I617a09bfaccdd0e69e064bec4ea749e08f2e1d74 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-cantools_37.0.7.bbappend4
-rw-r--r--recipes-devtools/python/python3-cantools_agldemo.inc3
2 files changed, 4 insertions, 3 deletions
diff --git a/recipes-devtools/python/python3-cantools_37.0.7.bbappend b/recipes-devtools/python/python3-cantools_37.0.7.bbappend
index a4c6aa3a..17531c73 100644
--- a/recipes-devtools/python/python3-cantools_37.0.7.bbappend
+++ b/recipes-devtools/python/python3-cantools_37.0.7.bbappend
@@ -1,3 +1 @@
-RDEPENDS:${PN} += "\
- python3-argparse-addons \
-"
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'python3-cantools_agldemo.inc', '', d)}
diff --git a/recipes-devtools/python/python3-cantools_agldemo.inc b/recipes-devtools/python/python3-cantools_agldemo.inc
new file mode 100644
index 00000000..a4c6aa3a
--- /dev/null
+++ b/recipes-devtools/python/python3-cantools_agldemo.inc
@@ -0,0 +1,3 @@
+RDEPENDS:${PN} += "\
+ python3-argparse-addons \
+"