summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-10-30 17:47:48 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-04 14:37:10 +0000
commit541493df5008c92acd42a2bfa01e8deb24774e11 (patch)
treec30c12d26aaa9e1f6fa5ce9444141083724ac043 /recipes-devtools
parent528aee6d5dd788f6a9d610cb996bf898461757c0 (diff)
python3-pyqt5: enable SVG support
Add a bbappend for python3-pyqt5 to enable its QtSvg module that exposes Qt's SVG support. This is required for agl-demo-control-panel. Bug-AGL: SPEC-4952 Change-Id: Ic8ae0816227306139b6e14cbe6974bcfeffcef7f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29345 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Lisandro Perez Meyer <lpmeyer@ics.com> ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-pyqt5_5.15.1.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend b/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend
new file mode 100644
index 00000000..408c48b3
--- /dev/null
+++ b/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend
@@ -0,0 +1,9 @@
+# Enable SVG support
+DEPENDS:append = " qtsvg"
+PYQT_MODULES:append = " QtSvg"
+
+# Fix python interpreter paths in pyrcc5, etc., adapted from newer upstream
+# recipe
+do_install:append() {
+ sed -i "s,^exec .*python${PYTHON_BASEVERSION},exec ${bindir}/python3," ${D}/${bindir}/*
+}