summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-05-12 15:09:57 -0400
committerScott Murray <scott.murray@konsulko.com>2023-05-15 18:44:12 +0000
commit6533623201bf90c56a4a611519fab8923e127b2a (patch)
treebe5ebf12a94bd0611aa1e8fdcdbdb2e26aa2328b /recipes-devtools
parenteb5c52e3d293d358e114312b35ad9d1a9d4b8ae9 (diff)
Add vss-tools and required dependencies
Add a vss-tools recipe to build the VSS specification tools, and recipes for the python3-anytree, python3-deprecation, and python3-graphql-core modules it requires. The latter will be submitted for meta-python. Bug-AGL: SPEC-4761 Change-Id: Iffe665c0c6f168f3c37b35ce0346cad210d880c5 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-anytree_2.8.0.bb16
-rw-r--r--recipes-devtools/python/python3-deprecation_2.1.0.bb12
-rw-r--r--recipes-devtools/python/python3-graphql-core_3.2.3.bb12
3 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-anytree_2.8.0.bb b/recipes-devtools/python/python3-anytree_2.8.0.bb
new file mode 100644
index 00000000..1b4628a9
--- /dev/null
+++ b/recipes-devtools/python/python3-anytree_2.8.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Powerful and Lightweight Python Tree Data Structure"
+HOMEPAGE = "https://github.com/c0fec0de/anytree"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "anytree"
+
+SRC_URI[sha256sum] = "3f0f93f355a91bc3e6245319bf4c1d50e3416cc7a35cc1133c1ff38306bbccab"
+
+inherit pypi setuptools3
+
+do_install:append () {
+ rm -f ${D}${prefix}/LICENSE
+}
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-deprecation_2.1.0.bb b/recipes-devtools/python/python3-deprecation_2.1.0.bb
new file mode 100644
index 00000000..c4b3a1cf
--- /dev/null
+++ b/recipes-devtools/python/python3-deprecation_2.1.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A library to handle automated deprecations"
+HOMEPAGE = "https://github.com/briancurtin/deprecation"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "deprecation"
+
+SRC_URI[sha256sum] = "72b3bde64e5d778694b0cf68178aed03d15e15477116add3fb773e581f9518ff"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-graphql-core_3.2.3.bb b/recipes-devtools/python/python3-graphql-core_3.2.3.bb
new file mode 100644
index 00000000..b12957a4
--- /dev/null
+++ b/recipes-devtools/python/python3-graphql-core_3.2.3.bb
@@ -0,0 +1,12 @@
+SUMMARY = "GraphQL implementation for Python"
+HOMEPAGE = "https://github.com/graphql-python/graphql-core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=73706fb002de2debc52328afd1688817"
+
+PYPI_PACKAGE = "graphql-core"
+
+SRC_URI[sha256sum] = "06d2aad0ac723e35b1cb47885d3e5c45e956a53bc1b209a9fc5369007fe46676"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND += "native nativesdk"