summaryrefslogtreecommitdiffstats
path: root/recipes-extended/foo/vhost-device-sound_0.1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-04-06 23:55:42 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-04-06 23:58:07 +0200
commit5f1c3868c5353d89eb8b3396d88d0e70f2e99ab4 (patch)
tree16a1a1db347b37b232f9b6b8e0fa6cd798a809d4 /recipes-extended/foo/vhost-device-sound_0.1.0.bb
parent68c88e1854abfa49ed98743398d64bdff7ebb3fa (diff)
Change-Id: Ia4c741323a705692219057174e00a083a97da16d Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-extended/foo/vhost-device-sound_0.1.0.bb')
-rw-r--r--recipes-extended/foo/vhost-device-sound_0.1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-extended/foo/vhost-device-sound_0.1.0.bb b/recipes-extended/foo/vhost-device-sound_0.1.0.bb
new file mode 100644
index 00000000..8b82b4d0
--- /dev/null
+++ b/recipes-extended/foo/vhost-device-sound_0.1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A virtio-sound device using the vhost-user protocol."
+HOMEPAGE = "https://github.com/rust-vmm/vhost-device"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE-APACHE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://LICENSE-BSD-3-Clause;md5=2489db1359f496fff34bd393df63947e \
+"
+
+DEPENDS += "alsa-lib pipewire clang-cross-${TARGET_ARCH}"
+
+SRC_URI += "crate://crates.io/vhost-device-sound/0.1.0"
+
+inherit cargo cargo-update-recipe-crates pkgconfig
+
+include vhost-device-sound-crates.inc
+
+SKIP_RECIPE[vhost-device-sound] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'clang-layer', '', 'Depends on clang-native from meta-clang which is not included', d)}"
+