summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-01 15:32:22 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-17 22:18:31 +0000
commit8ec9bc64f6bf1fb5b4208050392d2b1011c02222 (patch)
tree105c485398cdd1dc50b6aff5a4f385473fbee189 /recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
parent1152f0e593f9179465ec0d996ff23adaefa2b926 (diff)
Update wayland-ivi-extension to 1.11.0
* remove unused recipes wayland-ivi-extension 1.5.0 * fix patch 0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch for the new version 1.11.0 of wayland-ivi-extension. Bug-AGL: SPEC-411 Change-Id: Icb9d7b40bfdd6a2df20cc2916ff0325dc31afab6 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
new file mode 100644
index 00000000..16553da6
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
@@ -0,0 +1,29 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+ -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+ "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+ -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+ "
+
+PACKAGECONFIG ??= "ilm_input test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
+
+SRC_URI_append = "\
+ file://0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch \
+ file://cmake-find-gtest.patch \
+ file://test-path.patch \
+ "
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+ ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+ ${libdir}/${PN}/test/ivi-input-api-test \
+ "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"