summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend
diff options
context:
space:
mode:
authorMikhail Durnev <mikhail_durnev@mentor.com>2015-10-20 20:57:57 +1000
committerMikhail Durnev <mikhail_durnev@mentor.com>2015-10-23 13:23:27 +1000
commit0535df2c32dc562bd5f7704a599b982bc9e102df (patch)
tree75b95bccbc72362bd1c645ef07b8ca16279b56a1 /recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend
parentd272cfddde1bffa2b31cb5af382198e300d3a619 (diff)
wayland-ivi-extension: Build unit test apps
The wayland-ivi-extension package provides unit test applications. The recipe was modified to build those apps and install them on the target in a separate ipk/rpm package. The test apps are not compatible with ptest. Ctest is required to run them on the target. Change-Id: I937fde52eafc20f38ab7c8ff2d2981cc4f836f33 Signed-off-by: Mikhail Durnev <mikhail_durnev@mentor.com>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend
index f30bf7f1..da97895a 100644
--- a/recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.5.0.bbappend
@@ -1,5 +1,28 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+ -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+ "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+ -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+ "
+
+PACKAGECONFIG ??= "test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
SRC_URI_append = "\
file://0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch \
+ file://cmake-find-gtest.patch \
+ file://test-path.patch \
"
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+ ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+ ${libdir}/${PN}/test/ivi-input-api-test \
+ "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"