summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-18 08:31:54 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-18 08:31:54 +0000
commit26eb2df7ca7b6db058a1c368c550abd203f4b2d8 (patch)
tree6377ac495441e6cc25e40d6e4b657d7d7859c838 /recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
parent8ec9bc64f6bf1fb5b4208050392d2b1011c02222 (diff)
Temporarily revert Update wayland-ivi-extension to 1.11.0 from series
jsmoeller: I merged this one too early. We need to merge the whole series. Revert "Update wayland-ivi-extension to 1.11.0" This reverts commit 8ec9bc64f6bf1fb5b4208050392d2b1011c02222. Change-Id: If5c0228c7cab6a9c2576abd76feaae59bffab781 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
new file mode 100644
index 00000000..56574eb1
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
@@ -0,0 +1,28 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+ -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+ "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+ -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+ "
+
+PACKAGECONFIG ??= "ilm_input test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
+SRC_URI_append = "\
+ file://0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch \
+ file://cmake-find-gtest.patch \
+ file://test-path.patch \
+ "
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+ ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+ ${libdir}/${PN}/test/ivi-input-api-test \
+ "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"