summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-05 10:08:59 -0400
committerScott Murray <scott.murray@konsulko.com>2023-06-07 13:33:53 -0400
commit2507e4a69862808a6331b0e4c665b694f49a49b9 (patch)
tree7031fe828a07407a21dcf82dd37fbd1774d5f6af /recipes-graphics
parentcce52591f8e00ae41ae380a597d620b0856d004d (diff)
Remove systemd user session and clean up packagegroups and imagespike_15.91.0pike/15.91.015.91.0
Remove the use of systemd user session to align with how upstream runs Weston, and to allow using all systemd sandboxing features with the compositor and homescreen, launcher, etc. applications. The changes for this touched enough packagegroups and images that further rework was done to address some of the cleanup described in SPEC-4813, see below for details. Changes: - Rework systemd units and recipes of affected applications. - Rework images to pull in image .bb files instead of .inc files. - Pull in the new agl-image-compositor as a base image where appropriate. - Update weston-terminal-conf recipe to use new split out weston-terminal package. - Use new agl-crosssdk bbclass where appropriate. - Pull some local common cross-SDK additions into a new agl-ivi-crosssdk.inc include file and use as appropriate. Note that this does have a side effect of likely correcting the contents of agl-image-ivi-crosssdk for some recent additions. - Remove flutter-gallery bbappend that turned it into an app, as we are not using it in images, have other examples now, and it seems better to not affect the contents of agl-image-flutter. - Remove unused agl-image-graphical-html5. If a downstream user does desire an image with Chromium+WAM without applications, restoring it can be considered. - Remove unused agl-image-graphical-qt5-crosssdk. - Remove all packagegroup-agl-profile-* packagegroups, as they were either empty or not providing value at this point. Any future plans for defining profiles can start from a clean sheet. - Added new packagegroup-agl-ivi-multimedia-hardware to hold some rcar3 specific additions (via override) that were previously being appended onto packagegroup-agl-graphical-multimedia even though they are machine-specific and that packagegroup is not. This may be a stopgap solution if the agl-ivi-* packagegroups are reworked further. - Replace some :append usage with += to avoid creating problems for downstream users. Bug-AGL: SPEC-4714, SPEC-4813 Change-Id: I544b1495bed1e2e2412a8e46b7d20d7622ec28c9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb2
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf/org.freedesktop.weston.wayland-terminal.desktop11
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop12
3 files changed, 1 insertions, 24 deletions
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
index a34c4148..390edc8a 100644
--- a/recipes-graphics/wayland/weston-terminal-conf.bb
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -18,4 +18,4 @@ FILES:${PN} = " \
${sysconfdir}/systemd/system/agl-app@${AGL_APP_ID}.service.d \
"
-RDEPENDS:${PN} = "weston"
+RDEPENDS:${PN} = "weston-terminal"
diff --git a/recipes-graphics/wayland/weston-terminal-conf/org.freedesktop.weston.wayland-terminal.desktop b/recipes-graphics/wayland/weston-terminal-conf/org.freedesktop.weston.wayland-terminal.desktop
deleted file mode 100644
index 6c462870..00000000
--- a/recipes-graphics/wayland/weston-terminal-conf/org.freedesktop.weston.wayland-terminal.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=Weston Terminal
-Comment=Terminal Emulator
-GenericName=Terminal Emulator
-Exec=weston-terminal
-Icon=utilities-terminal
-Terminal=false
-Type=Application
-Categories=System;TerminalEmulator;
-StartupNotify=true
diff --git a/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
deleted file mode 100644
index d1cb2c88..00000000
--- a/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=Weston Terminal (systemd)
-Comment=Terminal Emulator
-GenericName=Terminal Emulator
-Exec=weston-terminal
-Icon=utilities-terminal
-Terminal=false
-Type=Application
-Categories=System;TerminalEmulator;
-DBusActivatable=true
-StartupNotify=true